Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I just completed the installation process for Ubuntu 13.04, and when it completed it said it needed to restart. After restarting, Windows 8 booted up, with no option for Ubuntu whatsoever.

share|improve this question

marked as duplicate by Warren Hill, Jorge Castro, Eric Carvalho, Kevin Bowen, Nathan Osman Oct 8 '13 at 2:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

4 Answers 4

up vote 0 down vote accepted

Try to remember if you have either installed grub that is broken, or that you didn't have grub, try to boot into a live CD and install boot repair via terminal.

Commands are following:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

Now you should be fine, it automatically detects your operating systems and you can boot in Ubuntu also!

share|improve this answer
    
I did this and it worked! I guess it was a grub issue. –  user199470 Oct 7 '13 at 22:35
add comment

do you remember where you put the bootloader grub? There were the two possibilities to put it either to the mbr (e.g. /dev/sda) => in this case your ubuntu should have booted right. Or to put it to the root-partition (e.g. /dev/sda2). In this case you would have reainstall it to mbr, e.g. via "grub rescue disk"

share|improve this answer
    
I don't recall doing anything with grub, so maybe that's my issue. I made a bootable linux USB, booted to the USB, and then told it to install. I didn't do anything more specific than that. –  user199470 Oct 7 '13 at 22:05
add comment

When I installed Ubuntu, it didnt change the default boot option at all.

Startup into UEFI/BIOS by holding f2 button, then select Ubuntu as the default boot option. then, upon starting, you should see the Ubuntu boot menu, where you can choose what to boot.

If you dont have the Ubuntu boot option, or your Windows menu item doesnt work, then you could try looking at this thread:

Ubuntu 13.04 install gone wrong: no GUI in ubuntu and CANNOT boot into Windows 8

share|improve this answer
    
When I boot in to UEFI/BIOS there is no option for Ubuntu. There are a few options, one of them is my main drive, and the other wasn't anything I recognized. When I tried it, it booted me into Windows 8 the same way anything else did. –  user199470 Oct 7 '13 at 22:09
add comment

I am not sure, because I don't have windows 8 but on this page they mention you should disable FastStartup in windows 8. I can imagine this could cause grub not to be loaded. please let me know if this helps, I see a similar question pop up more often and I would like to know if I should suggest this answer.

share|improve this answer
    
I had disabled FastStartup, so that wasn't the issue.I was assuming it might have been somehow related to Secure Boot, but I'm not sure. No solutions for disabling secure boot have worked for me. –  user199470 Oct 7 '13 at 22:08
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.