Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I got a new laptop an Asus Q501L and I went to install Ubuntu 13.04 alongside Windows 8. I had problems booting to the LiveUSB but managed to work around the bios I ran the Boot Repair using the try Ubuntu and installed Ubuntu with the run alongside Windows 8 option. Well now when I boot it skips Grub and goes straight to Windows 8 and now when I try to log into the Live USB it stops loading saying it can not mount so I can't re-run Boot Repair. Any help would be nice because I need Ubuntu in order to do some of my assignments.

share|improve this question

2 Answers 2

Perhaps windows remains the default startup option in the UEFI/BIOS (They look the same but i expect you have UEFI if your computer is so new). Ive noticed on my computer that Ubuntu doesnt change the default boot option. Therefore, it will never go to the Ubuntu bootloader (grub2).

I suggest starting up in the UEFI by holding f2 upon startup, then selecting Ubuntu as the default startup option.

If you dont have Ubuntu as an option in that screen, or you do and it doesnt work, then there is an issue with the installation. I suggest re-creating the live USB in WIndows then trying boot repair. You may need to disable 'UEFI secure boot' to boot from the liveUSB - I had to, because the LiveUSB was unsigned.

If the Ubuntu default boot gives you an error about the signature instead of starting up - it means Ubuntu grub2 is working and UEFI is blocking the boot (because UEFI secure boot is enabled). You could just leave secure boot disabled but this exposes every OS on your computer to the related risk.

An unsigned Ubuntu installation can be fixed by running boot repair to install the signature key, so that you can boot Ubuntu with 'UEFI secure boot' enabled. In boot repair advanced options look for the option that mentions secure boot or signature. (Dont select or say yes to any option to create backup of EUFI/boot files, it will disable the windows bootloader)

share|improve this answer

did you selected the secure boot option in your bios that you can select if you have windows 8?

try to turn it off and see if you can reach the grub boot loader, on asus motherboards it is very easy to do!

if not try to delete ubuntu, and deselect the secure boot option and install ubuntu then.

share|improve this answer
    
yeah I needed to turn it off in order to get the LiveUSB to work. –  user199445 Oct 7 '13 at 10:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.