Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently running Ubuntu 11.04 beta 2 with unity on a laptop Dell XPS M1330. My Dell M1330 has an Intel chipset and this is the result I get for running the lspci -nn | grep VGA command:

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c)

I have a 22" display at home, so I like to configure my laptop to have dual displays (with the Monitor preference GUI tool). The way I use it is with an extended screen where each display (my laptop and my other 22" LCD each works with their native resolution). Everything works quite well except for a little annoyance which I was hoping someone can help me figure out. Even though my LCD is configured to be on the left and my laptop on the right (that is how the two are set up on my desk), the launcher and top-right Ubuntu icon that brings up the Dash always appears on my laptop screen, when I would like it to appear on my left screen. I attached a picture to visualize this better.

Any help would be greatly appreciated.enter image description here

BTW, I checked out this question, and it doesn't really cover what I'm asking here.

Thanks.

share|improve this question
    
Just a small clarification, in case it was not clear. When I move my mouse from the right (laptop) to the left (LCD screen) it crosses smoothly between the two. So my launcher actually appears in the "center" of my extended display. –  S B Apr 16 '11 at 14:54
    
Apparently, people have filed a bug which describes this unnatural behavior... –  S B Apr 16 '11 at 15:07
1  
OK, so apparently, as I mentioned before there's an open bug for this. But one of the comments for this bug (by Tich) gives a workaround which solves this problem. I am not xrandr expert, so please use this at your own risk. I can only attest that it works for me and my setting which I described above. xrandr --output HDMI1 --primary where HDMI1 represents my LCD screen. One should run xrandr to see what represents each of the displays. –  S B Apr 16 '11 at 15:17
    
Can you add what kind of hardware you have on the M1330? iirc it's either nvidia or intel video. –  Jorge Castro Apr 16 '11 at 20:51
    
@Jorge hardware info updated as requested. –  S B Apr 24 '11 at 11:04

1 Answer 1

up vote 5 down vote accepted

I had a similar problem, and someone directed me to the command xrandr.

Apparently the Unity Launcher appears on the screen set as "primary", and this can be changed with xrandr.

First run xrandr to get a list of outputs. For example, on my setup I get a bunch of things called DFP1, DFP2, CRT1 etc. After you have identified which of these is your external monitor, run

xrandr --output XYZN --primary

where XYZN is the output name (I have to run this for one called DFP5 sometimes). The launcher should immediately move to the output you chose.

share|improve this answer
    
Val, thanks for the answer. This is exactly the same solution which I found following the bug report above. This is clearly a workaround, and I hope that this issue will be fixed in a more accessible manner. I am hoping for a combo box in the monitor settings which lets you select which screen is primary. That seems like an "easy" fix. Maybe a "bitesize" bug? –  S B Apr 16 '11 at 15:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.