Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu alongside Windows, and now nothing is working right. When I turn on the machine, the display appears blank until the login screen appears. No OS selection menu (which I had), no Ubuntu boot splash screen (which was also appearing), nothing. I feel like the display is disabled until Ubuntu boots up, because I don't even get the manufacturer boot screen. For instance, when I press the delete key to enter the BIOS setup, the Ubuntu login screen never appears, but neither does anything else. Same as if I press the down arrow and enter at the time I assume the OS selection menu is onscreen. Except it's not on screen, because the screen isn't even on - it remains off (not just blank, I can tell it's off). What do I do?

The weirdest part is that everything was working fine, manufacturer logo, boot selection, and Ubuntu splash all appearing, for a few days, until today. In the beginning I did have some issues getting things to work since my system is UEFI, but it was working, but now it has seemingly randomly stopped. One thing worth noting is that at one point after this malfunction I tried mounting the Windows partition, and I got this error:

The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

It's certainly plausible that Windows could be hibernated, but I have no idea how to un-hibernate it because of the above issue.

My system is an Asus Q400A. Intel Core i7 3632QM, 8GB memory, HDD replaced with a 128GB Crucial M4 SSD.

share|improve this question
    
If windows is hibernated, then 'resume and shutdown Windows fully' as said in the message. –  minerz029 Oct 7 '13 at 0:34
    
And I can't, as said in the question. –  D. Strout Oct 7 '13 at 0:35
    
When in GRUB, press the down arrow 4-5 times then press enter, assuming Windows is the last menuentry. –  minerz029 Oct 7 '13 at 0:37

1 Answer 1

up vote 0 down vote accepted

OK, I seem to have solved the problem, though I'm still unsure exactly what was happening. It seems when I told Ubuntu to shut down, it wasn't shutting down completely. I noticed the power light would be flashing like it does when on standby, so I tried something different. I shut Ubuntu down from the terminal with sudo shutdown -h now, then unplugged the laptop and removed the battery. This removed all possibility of the computer being on in any way. When I plugged back in and started up, voila: manufacturer splash logo, GRUB, and I could choose Windows.

The laptop being on standby (mostly) explains why I couldn't access anything else, since it would resume straight to Ubuntu rather than doing a full startup sequence. However, it certainly doesn't make sense that Ubuntu would not shut down when I told it to the regular way, nor that I could avoid the Ubuntu login screen appearing by pressing keys similar to GRUB selections and BIOS menu triggers. Furthermore, I got the full Ubuntu login screen when I would try to start up, not the lock screen which I would expect if it were truly on standby. Furthermore, when I managed to get Windows started, it did not appear to have been in hibernation.

Does any of this make sense? No. Did I manage to get things working despite that? Yes. Does anyone have any idea why this is? Do let me know.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.