Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using the following instruction to install and configure Hadoop on Ubuntu 10.10.

I tried to save the compressed tar.gz file to /usr/local/ but it just won't save.

I've tried saving the tar.gz in my home folder and desktop and copying the files to the desired folder, but I get an error that tells me I don't have permission.

How do I save and extract a tar.gz folder to /usr/local/hadoop?

share|improve this question
The instructions there say you should be using sudo to execute commands. If you're following those directions to the letter the problem might be that you don't have sudo privileges. Is this a machine that someone else is the primary administrator of? – Amanda Nov 21 '11 at 1:59
up vote 3 down vote accepted

You need to be root to write to /usr/local. Run the file manager as root using

gksu nautilus

Then copy and paste or extract the archive.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.