Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everything worked normally, but suddenly when I turned my computer on the resolution was messed up. I couldn't set up any wide screen resolution.

At first I was thinking riva tuner on win messed it up, because riva did the same thing on win. I fixed that and still nothing.

I tried reinstalling Ubuntu and updating drivers, but nothing worked; so if anyone can help me, I'd appreciate it.

share|improve this question
    
Welcome to Ask Ubuntu! Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding more detail? askubuntu.com/questions/14008/… –  Jorge Castro Apr 16 '11 at 20:47
add comment

1 Answer

One way you might be able to get around this is to edit your xorg.conf file and force the other resolutions to be available.

The file normally lives at /etc/X11/xorg.conf.

First check to see if you have one. Then:

  • if you do, and you're using Maverick or later, but think you've never touched that file, make a backup of it (in case things go wrong) and then delete the file and restart (you may need to use sudo). Xorg in the latest versions of ubuntu can survive without one and will make up its own settings as best it can. If that doesn't work then put the backup back where you found it and edit it as below.

Once you have a file there are numerous tutorials on the web about how to edit it, but a good one is here: http://ubuntuforums.org/showthread.php?p=129379

If you add some lines about certain resolutions as per the link above, it should force X to use certain resolutions.

If that doesn't work however then the problem may not be with Xorg at all, but I'd try this first.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.