Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just recently installed 12.04 LTS on my machine. It's dual boot with Windows 7 on the other side.While on Windows I have a solid connection with full bars all day long. However, on the Ubuntu side, I have 3 out of 4 bars, and the connection is constantly dropping.It only disconnects for a second or two, but in doing so, it disconnects my VPN. So I have to monitor my wifi icon.

My machine is Toshiba Satellite L755

I tried sudo iwconfig wlan0 power off in terminal , but i get this:

Error for wireless request "Set Power Management" (8B2C) : SET failed on device wlan0 ; Operation not supported.

After going to system settings>additional hardware drivers I get "No proprietary drivers are in use on this system"

When I run sudo lspci and I get these results:

Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b4)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a4)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
03:00.0 Ethernet controller: Qualcomm Atheros AR8152 v2.0 Fast Ethernet (rev c1)

So I downloaded latest driver from Realtek website, copied to desktop, and extracted it. In terminal i run
sudo apt-get install gcc build-essential linux-headers-generic linux-headers-$(uname -r)
for necessary dependencies. I then enter
cd ~/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013
make
make install

Command Terminal read out.At this point I get a long scroll with a few mentions of error1 and error 2. I try to reboot the computer with
sudo modprobe -v rtl8188ee
but it says it cannot be found. So I manually reboot, and nothing changes under "Additional Drivers" scan. So I can't tell if I'm not installing correctly, or if there is something else going on.

Sources I've used so far:

http://ubuntuforums.org/showthread.php?t=2162026

step by step Ubuntu 12.04 install of Realtek RTL8188CE driver

Here's what I get after entering

cd ~/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013

make clean 

in the terminal: Make clean prompt Ok. After following the steps in the answer provided by Chili555 below, I believe everything went smoothly. It's worth stating that after entering the

sudo modprobe rtl8192ce

command, nothing happened. So I rebooted manually. I now have all bars lit up in my wifi icon (as opposed to before, when I only had 3)

Chili555 put up a text file in the comment section below that shows what it should look like when entering the 4 lines of code in gedit. That was very helpful. Also, be mindful of where your directory is when entering a command in terminal for cleaning up download. I specified "desktop" because that's where my extracted zip was located.

EDIT: THE NEXT DAY, Well after spending the evening on Ubuntu, I found that I am still in the same boat as before. I still have not been able to fix this issue of intermittent disconnects.

share|improve this question
    
You can just copy&paste text from the terminal - please don't use screenshots for that. Make sure you format it properly using the <$> button in the editor toolbar. –  gertvdijk Oct 6 '13 at 19:52
    
It works ! with sudo modprobe rtl8188ee for me. Thanks ! –  user324892 Sep 8 at 16:38

2 Answers 2

First, let's clean up the file from your first attempt:

cd Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013
make clean

Now, let's modify one file:

gedit pci.h

At the top of the file,after the comment section all out lined in **, add this sequence:

#ifndef __devinit
#define __devinit
#define __devinitdata
#endif

Proofread carefully, save and close gedit. Now do:

make
sudo make install

Finally, I believe the driver you need is rtl8192ce and not rtl8188ee:

sudo modprobe rtl8192ce

Your wireless should now be working.

share|improve this answer
    
I copied and pasted the first command you have, and hit enter. I get " No rule to make target 'clean'. Stop" What am I missing? Am I misunderstanding how to enter it in command terminal? Thanks –  5th Wheel Oct 6 '13 at 19:13
    
Are you in the correct directory? ~/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013 If you list the contents of the directory, do you see the Makefile?: ls –  chili555 Oct 6 '13 at 19:43
    
Ok, I just edited my question. You're right, I had to not just copy and paste, but specify desktop. Am I on the right track? –  5th Wheel Oct 6 '13 at 19:50
    
Yes, indeed. Please proceed. –  chili555 Oct 6 '13 at 19:51
    
One last thing, sorry, but I entered the code in pci.h. Just want to make sure I am entering in the right spot, as well as should I delete the 2 pieces of line that was there before? Could you have a peak at my edit? Thanks again –  5th Wheel Oct 6 '13 at 20:06

Excuse chili555, can I get help installing this but for the rtl8723ae driver? I get 2 errors and does not seems to work fine.

share|improve this answer
    
Have you gone to the link I posted above "ubuntu forums.org" thread. The link is in the second post by Verunda. Then click on the download link that is closest to your region. –  5th Wheel Oct 7 '13 at 20:47
    
I am having trouble finding the link, is it on this thread? (Sorry I am new here) *Found it, thanks I will reply back if it works. –  Alejandro_JD Oct 7 '13 at 21:47
    
I do not find my driver, mine is rtl8723ae and it is not there. –  Alejandro_JD Oct 7 '13 at 21:52
    
At this point you're going to have to start a NEW question. Click on " Ask Question" button in the top/right. I'll try to help you from there. But we can't use the comment section here for troubleshooting ( forum rules) –  5th Wheel Oct 7 '13 at 22:01
    
Ok, post is done. –  Alejandro_JD Oct 7 '13 at 22:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.