Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu using partitioning. Im using Windows 8 64-bit and I was following a Youtube tutorial. The installation worked great, but when after it prompted me to restart the computer, I couldn't load Ubuntu- and I know I downloaded everything correctly. I've tried using the msconfig command on run, and I checked the OSs I have, and it only says Windows 8? I've tried booting my USB again (which is what I used initially) and it also acts as if I never downloaded Ubuntu and gives me the option of installing or run without installing. What is going on? I even deleted my partitions (ultimately meaning I deleted ubuntu), made them again and re-downloaded Ubutntu, and the same thing happened. How do I get Ubuntu up and running, and how do I locate it?

share|improve this question

2 Answers 2

I think your problem may lie with UEFI. Make sure if you are booting UEFI that you have the newest version of Ubuntu (12.04 was the first to support Secure Boot and UEFI), and that you are using a 64 bit version of Ubuntu (64-bit PC is AMD64 even if you run Intel).

Ubuntu will not install as EFI as a 32-bit version, so a 32-bit Ubuntu with a 64-bit Windows will not install as EFI. This means that your BIOS will not boot or load the partitions, and only Windows will boot.

So here is what I recommend: Disable UEFI and Secure Boot. Boot your computer. If Ubuntu is installed properly grub should load. If it does, enable UEFI and reinstall Ubuntu with a 64 bit version. If it does not load properly (still straight to Windows), then something is wrong with the way you installed Ubuntu. The goal here is to rule out UEFI as your issue (which I'm pretty sure it is).

Here is some good information on UEFI: https://help.ubuntu.com/community/UEFI

I had to disable secure boot as Grub has a known bug for booting windows with Secure Boot right now.

EDIT: I was confused with UEFI and Secure Boot when I first got into this, so I wrote a short summary on this page as I understand it.

share|improve this answer
    
I downloaded 13.04, the latest version. And how do I change this UEFI mode? –  83457 Oct 6 '13 at 14:48
    
You just need to install with a 64 bit version with UEFI enabled in your BIOS. Is your version 64 bit? Another option... just to test if this truly is your issue is to disable UEFI and Secure Boot and see if it will boot. –  Diesel Oct 6 '13 at 14:52
    
Enter your BIOS setup (F2, F8 or whatever your manufacturer set) and check wheter EFI Mode is enabled. If not, enable it. –  the_Seppi Oct 6 '13 at 14:53
    
The other answer says Windows 8 PC's blocks non secure boot (I'd comment but don't have the reputation). just to clarify I added a page with a summary of UEFI and Secure Boot. It has nothing to do with Windows 8, UEFI is replacing BIOS and Secure boot is a feature of UEFI. Windows 8 has secure boot, so PC's with Windows 8 ship with it on by default. Ubuntu ALSO supports Secure boot, via Shim. Just GRUB has a bug right now that won't let you launch Windows 8 from Grub with Secure Boot Enabled as I posted. –  Diesel Oct 6 '13 at 15:01

Because Windows 8 supports Secure boot and UEFI, the PC's preloaded with Windows 8 normally have both UEFI and Secure boot Enabled for security. This will block every OS that doesn't support/conform to Secure Boot. Try updating your BIOS/EFI to the newest version. Maybe there is a "fix".

Btw.: msconfig lists the OS's written in the Windows MBR. I doubt you will see Ubuntu in there. And I think a Windows can't read EXT partitions.

share|improve this answer
    
Yes, Windows by default can not read the ext family of partitions unless additional software is installed. –  Ramchandra Apte Oct 6 '13 at 14:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.