Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tested Natty Beta 2 yesterday and found that the bookmarks button is hidden. The usual way to show it seems to be hiding the menubar under Customize, however there is no Menubar option in there now. Is there a way to show the bookmarks button?

I can download Firefox from Mozilla and use that version but that's not the best option.

share|improve this question
    
I was using Firefox 4 on Maverick. –  user14392 Apr 16 '11 at 11:32

4 Answers 4

up vote 3 down vote accepted

You could possibly disable the global menu extension to regain your bookmarks button. However, I wouldn't recommend this as the menu bar essentially recreates the bookmarks button without taking up any space.

share|improve this answer
    
Thanks ShroudedCloud, that's what I did. Problem solved. –  user14392 Apr 16 '11 at 11:30

Or you can put this code into your userChrome.css file:

#bookmarks-menu-button-container {display:-moz-box!important;}

In Firefox 23 and newer, the following may work instead:

#bookmarks-menu-button {display:-moz-box!important;}

The button will show up in her place and you don't have to disable the global menu extension.

You can always check for correct CSS selector by navigating to chrome://browser/content/browser.xul and using Firefox's Inspector in Developer Tools.

share|improve this answer
    
This is the correct answer, I think. The accepted answer is only a work-around with quite heavy side-effects. –  MPi Jan 3 '12 at 15:47

If you move the bookmarks button to another toolbar, like the add-ons bar or bookmarks bar, then it will be displayed.

share|improve this answer

The answer above is correct, but you can also pop it into your tab toolbar if you don't use a bookmark bar etc, which is what I did.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.