Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The other day I copied about 230GB of data from one external HDD to my new external HDD. I woke up, ensured that everything was working properly, and shut down the computer. Today I decided to use the new external HDD, and now neither Windows nor Ubuntu will recognize it.

This new external hard drive is less than a week old, but I can't do anything with it. Ubuntu sees it on Gparted, but it will not do anything. It says partition table unrecognized and my drive is supposed to be 3TB, while Gparted thinks it 13.75TB.

The data has already been deleted from the original source. Now this external HDD has the only undeleted copy of all 230GB of the original data. When I tried to recreate the partition table, it gave me an error pertaining to read and write. The new HDD's format table has been corrupted.

So now I want to recover the original data that I deleted from my old external hard drive, which is still working properly. Any advice would be appreciated.

share|improve this question
    
Can you explain a bit more how you copied it? –  MadMike Oct 6 '13 at 7:12
    
I was using windows explorer and did the normal drag and drop routine. Everything was copied succesfully according to windows and it worked until I shut down my computer now I'm getting this –  tyler Oct 6 '13 at 7:14
    
Show the output of the following commands: sudo fdisk -l /dev/sdb, sudo parted /dev/sdb print, sudo gdisk -l /dev/sdb, sudo hdparm -N /dev/sdb. (Change /dev/sdb in all of these commands to your disk's device ID, if it's not /dev/sdb.) Note that gdisk isn't installed by default, so you may need to install it by typing sudo apt-get install gdisk before running that command. Either edit your original question or provide a link to a pastebin site with these results. –  Rod Smith Oct 6 '13 at 17:23
    
I will do this after wprk tonight. –  tyler Oct 8 '13 at 16:24
    
I usually use photorec if I want to recover (many) deleted file, but usually is enough to do a backup of the "zombi" disk using ddrescue then have a look into the .img. Them manpage are well formatted :) –  gio900 Oct 14 at 13:18

1 Answer 1

Sounds like a hard disk going bad. I'd keep a close eye on this one.

To test it further, recreate the partition table, partition and format with gparted and try to copy it once more.

share|improve this answer
    
It will not allow me to....the ext hdd isless than a week old. If its going bad the its defective . I just wanna know if I can recover my 200+ gb that I just lost. And when trying to recreate partition table it gives error pertaining to read and write. Idont know I don't have it in front of me at this time sorry. –  tyler Oct 6 '13 at 9:46
    
Uhm, I thought you copied the data to your hdd. Now you say you moved deleting the original data? Is this so? –  MadMike Oct 6 '13 at 20:32
    
I copied the data from one hdd to my new one. The new hdds format table has corrupted. The data from the original hdd was deleted later and now I have lost it. –  tyler Oct 8 '13 at 5:40
    
This sounds pretty bad. You should: 1) Do the things @Rod Smith asks 2) Also try to recover the data from the original disk. –  MadMike Oct 8 '13 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.