Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had this working until a reinstall today. My home folder was on another disk so my ~/.smbcredentials file is fine. So it must be my fstab or app not installed. I have cif-utils installed and I've checked my search history for the guide i used but i can't seem to get it to work.

//kaboom.local/media    /home/noki/KaboomMedia  cifs    credentials=/home/noki/.smbcredentials,uid=1000,iocharset=utf8,noperm   0   0

On 'sudo mount -a' I get:

mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Through Unity I get it to mount through the cifs option and I can ping kaboom.local and get a response. Stupidly didn't backup my fstab, will this time.

Thanks, Noki

share|improve this question

1 Answer 1

up vote 0 down vote accepted

FIXED: I was missing a portion of the line in fstab, it seems I was incorrectly providing information about my user. Simply use 'id' to get this information on your system to apply to you're own fstab entry:

//kaboom.local/media    /home/noki/KaboomMedia  cifs    credentials=/home/noki/.smbcredentials,iocharset=utf8,dir_mode=0777,gid=1000,uid=1000,sec=ntlm  0   0

Not sure if all of those options are required but it is now working for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.