Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Update-manager Requires instalation of untrusted packages


apport apport-gtk gnome-settings-daemon ifupdown libldap-2.4-2 libpulse-mainloop-glib0  
libpulse0 libpulsedsp pulseaudio pulseaudio-module-bluetooth pulseaudio-module-gconf  
pulseaudio-module-x11 pulseaudio-utils python-apport python-problem-report
share|improve this question

marked as duplicate by Mitch, guntbert, karel, Nathan Osman, belacqua Oct 9 '13 at 15:24

This question was marked as an exact duplicate of an existing question.

The answer to the problem i faced was found in the link… And this the script: sudo apt-get clean cd /var/lib/apt sudo mv lists lists.old sudo mkdir -p lists/partial sudo apt-get clean sudo apt-get update – frank tavares Oct 7 '13 at 14:52

It sounds like you are missing some public keys.

For each missing key you should run the following command:

sudo apt-key adv --keyserver --recv-keys [key number]

if you run apt-get update from the command line you should get output like the following:

W: There is no public key available for the following key IDs: 4D270D06F42584E6

W: You may want to run apt-get update to correct these problems

In this example you would do the following:

sudo apt-key adv --keyserver --recv-keys 4D270D06F42584E6

share|improve this answer
Thanks for the answer, cprofitt. I run "apt-get update" from the command line and i got some messages. Like this:W: GPG error: precise Release: The following signatures were invalid: KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 W: Failed to fetch Could not connect to "sudo apt-key adv --keyserver --recv-keys 1380828071" is the way to correct this error? – frank tavares Oct 6 '13 at 22:23
I run sudo apt-key adv --keyserver --recv-keys 1380828071 and the result was [sudo] password for fran: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.VbEUzi1tNq --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver --recv-keys 1380828071 gpg: "1380828071" not a key ID: skipping – frank tavares Oct 7 '13 at 9:38
If the key has expired the answer I gave would not work. – cprofitt Oct 10 '13 at 2:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.