Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Update-manager Requires instalation of untrusted packages

Details

apport apport-gtk gnome-settings-daemon ifupdown libldap-2.4-2 libpulse-mainloop-glib0  
libpulse0 libpulsedsp pulseaudio pulseaudio-module-bluetooth pulseaudio-module-gconf  
pulseaudio-module-x11 pulseaudio-utils python-apport python-problem-report
share|improve this question
    
The answer to the problem i faced was found in the link askubuntu.com/questions/184117/… And this the script: sudo apt-get clean cd /var/lib/apt sudo mv lists lists.old sudo mkdir -p lists/partial sudo apt-get clean sudo apt-get update –  frank tavares Oct 7 '13 at 14:52
add comment

marked as duplicate by Mitch, guntbert, karel, Nathan Osman, belacqua Oct 9 '13 at 15:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

It sounds like you are missing some public keys.

For each missing key you should run the following command:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys [key number]

if you run apt-get update from the command line you should get output like the following:

W: There is no public key available for the following key IDs: 4D270D06F42584E6

W: You may want to run apt-get update to correct these problems

In this example you would do the following:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 4D270D06F42584E6

share|improve this answer
    
Thanks for the answer, cprofitt. I run "apt-get update" from the command line and i got some messages. Like this:W: GPG error: debian.wgdd.de precise Release: The following signatures were invalid: KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 KEYEXPIRED 1380828071 W: Failed to fetch pt.archive.ubuntu.com/ubuntu/dists/precise/Release.gpg Could not connect to pt.archive.ubuntu.com:80 "sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1380828071" is the way to correct this error? –  frank tavares Oct 6 '13 at 22:23
    
I run sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1380828071 and the result was [sudo] password for fran: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.VbEUzi1tNq --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 1380828071 gpg: "1380828071" not a key ID: skipping –  frank tavares Oct 7 '13 at 9:38
    
If the key has expired the answer I gave would not work. –  cprofitt Oct 10 '13 at 2:25
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.