Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having problems with USB sound for some time (it used to work about 6 months ago). I find that any USB sound device that I connect is not recognised, and is not listed by aplay -l

I've tried disabling pulseaudio. I've tried purging and re-installing alsa-base, pulseaudio, and pavucontrol. To no avail.

I'm using 12.04 LTS.

share|improve this question

closed as unclear what you're asking by Bruno Pereira Oct 31 '13 at 15:59

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Hi, following etiquette could you convert your solution to an answer (rather than in-line with the question) and mark it as the accepted answer. Thanks :) –  NGRhodes Oct 8 '13 at 12:04
add comment

1 Answer 1

Solution given by OP:

12.04 does not have the needed kernel module snd-usb-hiface this is introduced in the 3.11.1 kernel and installing that on 12.04 gives USB sound for my equipment. How to install the 3.11.1 kernel is given here:- installing 3.11.1 kernel

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.