Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Nexus 4 for testing purpose only. Today I decided to do a full wipe and install last image, so I did (I removed some uninteresting lines):

rpadovani@artemis:~$ phablet-flash ubuntu-system --channel devel --no-backup

INFO:phablet-flash:Waiting for recovery image to boot
INFO:phablet-flash:Wait for recovery image to boot complete
INFO:phablet-flash:Clearing /data and /cache
INFO:phablet-flash:Pushing /home/rpadovani/Downloads/phablet-flash/imageupdates/pool/ubuntu-d36f505e94afc8990c57f31db9812b5ee7466a155768388da3fdec5f8393867d.tar.xz to /cache/recovery/
protocol failure
ERROR:phablet-flash:Command 'adb push /home/rpadovani/Downloads/phablet-flash/imageupdates/pool/ubuntu-d36f505e94afc8990c57f31db9812b5ee7466a155768388da3fdec5f8393867d.tar.xz /cache/recovery/' returned non-zero exit status 1
Removing directory /tmp/tmp3pXqhs
Removing directory /tmp/tmpY58JGt

When it reboot it is stuck on the screen with the text "Google". After ten minutes I tried to reflash it, but it said:

rpadovani@artemis:~$ phablet-flash ubuntu-system --channel devel --no-backup
error: device not found
ERROR:phablet-flash:Command 'adb shell getprop ro.cm.device ' returned non-zero exit status 255

So I restore default Android version, but I have the same error when I try to reflash Ubuntu.

What can I do?

share|improve this question
    
Have you tried "devel-proposed" ? –  wojox Oct 5 '13 at 14:53
    
@wojox I had the same error... –  rpadovani Oct 5 '13 at 16:01
    
Can you add some details: Which exact build? (date/rev.) –  david6 Oct 5 '13 at 22:24
    
Version 82, 20131004.1 –  rpadovani Oct 5 '13 at 23:32

2 Answers 2

up vote 1 down vote accepted

Today I did a full wipe of Android, deleted phablet-flash/ in Downloads, enabled USB debugging and installed today version (83, 20131005) and it works... Bah!

share|improve this answer
    
I have also found the daily builds to keep breaking something (WiFi, boot, keyboard, music, SSH, etc.), but differently across the Nexus 4 (phone), Nexus 7 (7" tablet), and Nexus 10 (10" tablet). Its still beta, for now .. –  david6 Oct 7 '13 at 20:45

I had the same problem today. Try this:

  1. Power on the device by holding the Power button + volume up + volume down.
  2. The device will boot into the bootloader.
  3. Use the volume keys to scroll to Recovery and the power button to select it.
  4. Plug the device into the computer via the USB cable.
  5. Type the phablet-flash command extended with "-d mako" to manually specify what kind of device you have: phablet-flash ubuntu-system --channel devel --no-backup -d mako
  6. Wait until phablet-flash finishes with: INFO:phablet-flash:Installation complete
share|improve this answer
    
ERROR:phablet-flash:Command 'adb reboot bootloader' returned non-zero exit status 1 :( –  rpadovani Oct 5 '13 at 21:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.