Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed a dual boot system on an UEFI board with Windows 7 and Ubuntu 13.04 (both 64bit). Ubuntu is freezing during bootup very often. In most of the cases it's stuck on a blank orange background - but sometimes it's also freezing during the Ubuntu logo (with those "loading dots"). Occasionally, it ends up showing a console with strange codes like "([[2663". The only thing I can do then is pressing the reset button and trying again - there is a very small chance that the boot process succeeds showing me the login screen.

If I want to shut down or restart system (assumed I managed it to start Ubuntu), this does not work either. There is no signal on my screen anymore, but the PC keeps running and I have to restart / switch it off manually.

All of the problems mentioned above are appearing on Ubuntu only, while Windows 7 is able to boot, restart and shut down perfectly.

It might be important to know that I'm using a 128 GB SSD drive. I've read about a connection between the usage of SSDs and Ubuntu boot difficulties, but as those questions have been asked already one or two years ago, I cannot believe that there is still no solution available. Am I wrong?

Other hardware used in my system:

  • Gigabyte H87-HD3
  • GeForce GTX 760
  • Logitech G19 gaming keyboard
  • Intel i5 processor

Thanks for answers!

share|improve this question
1  
The erratic nature of the symptoms sound like a hardware problem to me. I'd go so far as to venture a guess at bad RAM. You might want to run a RAM-testing tool like memtest86 on the computer. You could also try booting in verbose mode to see error messages rather than the pretty but useless boot graphics. To do this, hit E rather than Enter to boot, then edit the linux line to remove the queiet splash options. Hitting F10 will then boot with the altered settings. (These changes are non-permanent, so don't worry about messing them up.) –  Rod Smith Oct 5 '13 at 16:05
add comment

2 Answers

Disable ncq.

Add kernel parameter libata.force=noncq in grub configuration after quiet splash:

sudo nano /etc/default/grub

So the line reads:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash libata.force=noncq"

Then do:

sudo update-grub
share|improve this answer
add comment

I was experiencing the same sort of erratic freezing on boot with a fresh install of 13.04 on a Toshiba SD 50-D laptop. I have AMD A10 processors and 6GB memory and Radeon graphics.

Symptoms where intermittent failing to boot after a clean shutdown, that progressed to total failing to startup. Ubuntu would get installed sometimes so that the mouse would respond, but it would never complete the installation to the login screen.

I was able to fix the issue on the Toshiba, it turns out that Toshiba has to places to change the boot actions and both have to changed to allow Ubuntu to install. I had to change the boot option [UEFI BOOT]. One of the options was [CSM BOOT] that allows booting from external devices.

  1. Boot
  2. Hold F2 during power up to get to the BIOS
  3. Tab over to the Advances tab
  4. Use the down arrow to get to the System Configuration (at the bottom) and press enter.
  5. Set the Boot Mode to CSM Boot
  6. Press F10 key to save and exit 7 Reinstall Ubuntu

Everything works fine now.

share|improve this answer
    
None of your hardware has relationship with the OP's hardware. –  Braiam Oct 8 '13 at 21:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.