Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have met this problem for quite a while(almost a year).

  • When i fresh open the computer, everything is fine, i can visit any website i like
  • however, after some time(12-24 hours), i can not visit most websites(yahoo,bing,ubuntu etc)
  • if i reboot my computer, the problem disappears, but the same pattern repeats, that is, atfer 12-24 hours, i can not visit most website.

I am pretty sure that it's not the problem of my network or computer hardware, it's the problem of ubuntu os itself. Because:

  • I tried to switch to windows and android, they don't have the problem.
  • I checked my dns and switched it to google's dns service(8.8.8.8,8.8.4.4), still not working.
  • my android phone and my laptop actually share the same wifi network and my phone don't have that problem

I searched this again and again, still can not find the right answer to solve it. And it seems that many people have encountered this problem.

Any one have the similar problem? How to get rid of it?

share|improve this question
    
sounds like you're running bit-torrent or something and your router is choking. a reboot forces your browser to refresh dns instead of accepting the stale unreachables and the router's table hasn't filled up with crap yet since torrents are still starting up/your connection count is low –  hbdgaf Oct 5 '13 at 11:45
    
No, I didn't use bit-torrent or transmission etc. I am pretty sure about this. I agree with you that it's somehow about the DNS. –  user2758004 Oct 5 '13 at 11:47
    
you're sure you are using bit-torrent or you're not. there is no pretty sure on app usage unless you are proxying a support request to AU. –  hbdgaf Oct 5 '13 at 11:48
    
I am not using any downloading software, i just use normal browsers(chrome firefox etc) to surf the web. And what is AU? –  user2758004 Oct 5 '13 at 11:50
    
If you're just using vanilla and only a browser, the only thing I've seen this happen with is sites that open a ton of connections and the router choked, the fact that a pirating website was browsed and your connection is throttled, or the ISP/your DNS server is lagging... and wireless bugs. –  hbdgaf Oct 5 '13 at 11:58
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.