Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Windows 7 32-bit laptop on which I installed Ubuntu alongside Win7. At first the problem was that it would boot directly into Windows without a boot menu as if Ubuntu didn't exist. I successfully used Boot Repair to get a boot menu and everything seemed fine. The next day I restarted the computer and now the computer won't boot at all. When the system is trying to boot I get the following:

PXE-E61: Media test failure, check cable
PXE-M0F: Exiting PXE ROM
Operating system not found

The only way I can start the computer is by inserting the USB flash drive with Ubuntu bootable files on it which lets me use Ubuntu but not install it. This is the flash drive I originally used to try Ubuntu and then install it. Using the Boot Repair a second time didn't help. The system doesn't recognize my hard drive at all. I tried using the recovery function of my Windows 7 DVD which gave me a "the partition table does not have a valid system partition" error. Windows CD also doesn't recognize a hard drive or an operating system on my system.

I have been browsing the forums but most other people with similar problems seem to have some sort of access to their hard drive but I haven't found a way yet. Can anyone help please?

share|improve this question
    
Did you use the 'something else' partitioning menu to install Ubuntu? –  minerz029 Oct 5 '13 at 7:27
    
Please post the URL that Boot Repair gives you; that will provide us with detailed information that's necessary to diagnose the problem with minimal guesswork. –  Rod Smith Oct 5 '13 at 16:54
    
@minerz029 Yes. Initially I tried that since I wanted to install ubuntu on a partition I had prepared earlier. But when I tried choosing that partition I kept getting an error about how no file system was chosen for the specified partition. I played with the file system choices in partition configuration but couldn't get the error message to go away so I decided to let Ubuntu install alongside Windows on the same partition instead. –  user198936 Oct 5 '13 at 19:30
    
@RodSmith Sure. The first time I successfully ran it to create a boot menu: paste.ubuntu.com/6191335 and the second time I ran it after windows failed to boot: paste.ubuntu.com/6194898. This time it didn't help. –  user198936 Oct 5 '13 at 19:32
add comment

1 Answer 1

Your first Boot Repair output shows three disks:

  • /dev/sda: A ~2GB disk (probably a USB flash drive)
  • /dev/sdb: A ~9MB (yes, MB) disk (I don't know what this is -- maybe a very old CF card or something)
  • /dev/sdc: A ~320GB disk (presumably your main hard disk)

Your second Boot Repair output shows /dev/sda and /dev/sdb, but there's no sign of /dev/sdc. This leads me to think that you may have some failing hardware. If you're lucky, it could be that the hard disk has worked itself loose, and that pulling it out and re-seating it will fix the problem. If you're unlucky, it could be that the hard disk itself is failing and needs to be replaced. If you're very unlucky, it could be that a trace on the motherboard or the circuit that controls the hard disk on the motherboard is failing, in which case the computer has become more-or-less useless. The fact that Windows is sometimes reporting disk problems makes a hardware problem seem even more likely, since you'd need similar bugs in both OSes to explain this problem on the software level.

It's conceivable that an examination of the Linux kernel ring buffer (obtained by typing dmesg soon after booting) will provide some clues -- there might be a message about a failure to initialize /dev/sdc (possibly without that name, but the disk's manufacturer's name or "ATA" might appear in the message). Unfortunately, dmesg output is rather long and can be difficult for novices to interpret. You could redirect it to a file (dmesg > foo.txt) and post it to a pastebin site if you want to show it to us.

You could also try running a SMART utility on the disk, like smartctl, GSmartControl, or the Palimpsest Disk Utility's SMART tests (in increasing order of user-friendliness). This will be helpful only if the disk is accessible when you boot the computer, and it will return useful results only if the disk itself is failing in certain ways. A SMART test won't reveal problems with the motherboard.

Moving the disk to another computer is another good diagnostic procedure -- if it works fine in another computer, then you know the problem is on the motherboard or is a result of a bad connection between the disk and the computer.

share|improve this answer
    
thank you for your response. I have uploaded thedmesg output to pastebin.mozilla.org/3201270 if you'd like to take a look. The hard drive is a Western Digital Black 320 G Mobile hard drive if that helps. Toward the end of the report there are 2 "SATA link down" lines. If that's what I should be looking for then I get this error when I am booting the computer using the Ubuntu USB and right after this error message the boot process slows down presumably because it receives no signal from the hard drive. –  user198936 Oct 5 '13 at 23:22
    
I replaced the hard drive about a year ago when the original one failed so I suppose it is possible it has come loose. I'll try to wiggle it back into place if that is the case and see if that makes a difference. Thanks again. –  user198936 Oct 5 '13 at 23:25
    
You've got a bunch of ATA errors on lines 769-802. I'm not sure precisely what they all mean, but their presence suggests a hardware problem. Reseating the drive makes sense as a test, and it might even fix the problem. If not, it looks less promising, I'm afraid.... –  Rod Smith Oct 5 '13 at 23:38
    
I just removed the HDD and reseated it, No change. I've ordered another one online. I guess I'll have to hope that it's not a motherboard issue. Thank you for your help. –  user198936 Oct 6 '13 at 5:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.