Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I don't use things like Ubuntu One. How do I disable it from Startup Applications? I believe it is hidden by default along with some other apps.

share|improve this question

marked as duplicate by guntbert, dobey, Warren Hill, aquaherd, Eric Carvalho Oct 5 '13 at 21:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 2 down vote accepted

You have to edit /etc/xdg/autostart/ and either:

  • remove the NoDisplay=true lines;
  • or make those same lines comments by adding # in front of them;
  • or replace true by false in those same lines.

The alternate solution can be easily done in three steps:

  1. Summon the terminal with Ctrl + Alt + T.
  2. Type the two following commands:

    cd /etc/xdg/autostart/
    sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop
    

After changing anything you want, you can go back to the previous state by typing this into the terminal:

sudo sed --in-place 's/NoDisplay=false/NoDisplay=true/g' *.desktop

This has been tested in 12.04, 12.10 and 13.04.

Sources: 1. This answer by chtfn 2. How to enable all the apps in the Startup Applications in Ubuntu

share|improve this answer
1  
Thanks. It works. :-) –  joon Oct 5 '13 at 5:38
    
It's fine. Just make sure that you search for existing Qs that may help you before yu ask another Q. (That's why I marked it a duplicate.) The +1s were just to welcome you to the community. :-) –  TomKat Oct 5 '13 at 5:44
1  
I want to remove Ubuntu One. Can you help me? askubuntu.com/questions/353987/remove-ubuntu-one –  joon Oct 5 '13 at 10:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.