Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I installed Ubuntu (13.04; before that I was using Windows) I haven't been able to use non-letters keys (such as 123[];/.,) in any application. When I was installing Ubuntu I chose Czech layout, but when I switch to US layout it makes no different. I have tried external keyboard (I'm using Lenovo ThinkPad E430), but it doesn't work either. Can someone help me please?

share|improve this question
1  
Are you sure that you switched correctly to US layout? Can you shou us a picture with your layout chart? –  Radu Rădeanu Oct 4 '13 at 22:16
    
Open a terminal, run the command xev, and in the xev window, type a non-letter key. What appears in the terminal (the block of 5 lines starting with “KeyPress event”)? –  Gilles Oct 4 '13 at 22:20

1 Answer 1

up vote 0 down vote accepted

If you use czech layout, you can type for example [ as follow:

czech layout chart

The things goes something like follows. Let's take for example this key:

czech key

To type ú - press ú.

To type / - press Shift+ú.

To type [ - press AltGr+ú.

To type ÷ - press AltGr+Shift+ú.

share|improve this answer
    
I'm sorry I just partly solved it myself. When I opened keyboard layout settings, the Czech layout was chosen as a primary layout (then it really makes no different which layout I was currently using and it didn't work). But I tried to changed it, so the US layout is the primary one now and it works perfectly. Now I can use non-letters keys in all application, but I cannot have Czech layout set as a default one. Is there some simple fix to this (Czech layout set as a default one and still be able to use non-letters keys)? –  Tatarkow Oct 4 '13 at 22:46
1  
@Tatarkow Yes, follow the instructions from the answer to type ant character do you wish when you use Czech layout. –  Radu Rădeanu Oct 4 '13 at 22:49
    
I maybe didn't express correctly, when I said in any application I didn't mean for example libre office (I know how to write symbols), I meant application like games or blender, where the keys do something. And the problem is that, if the Czech layout is set as a default layout, those programs won't register if I press the non-letter key or not. –  Tatarkow Oct 4 '13 at 23:05
    
@Tatarkow Well, the when you will go in a game, you can switch quickly between keyboard layouts. –  Radu Rădeanu Oct 4 '13 at 23:11
    
OK, at first I didn't change the layout properly, so there was no way to use those keys, which was a complication, but as I wrote I had discovered that, I hadn't change it properly and if I do, then it works (I still have to change the layout but it's not a big deal). I'm sorry for bothering you (I must look like an idiot now) and thank you. –  Tatarkow Oct 4 '13 at 23:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.