Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i've not much experience with wlan and ubuntu. I recently installed ubuntu 12.04 LTS on a Compaq PC. I therefore downloaded the newest 32-bit version from ubuntu.com

I checked the version with "lsb_release -a": Description says: Ubuntu 12.04.3 LTS

I checked the kernel version with "uname -rm": kernel 3.8...

I plugged the wlan stick (Netgear wg111v2) in and it worked but VERY slow (about 500 kbit/s) and several reconnects after some minutes.

I found out that ndiswrapper could be a solution for me but therefore i would need kernel 3.2 otherwise i get an error when: sudo modprobe ndiswrapper FATAL Module Ndiswrapper not found.

I tried to downgrade ubuntu to kernel 3.2 with these commands: (not sure if i did everything right!) sudo apt-get install linux-generic linux-image-generic linux-headers-generic linux-image-3.2.0-23-generic linux-headers-3.2.0-23-generic sudo apt-get purge linux-generic-lts-raring linux-image-generic-lts-raring linux-headers-3.8.0-29 linux-headers-3.8.0-29-generic linux-image-3.8.0-29-generic

then i did a reboot checked kernel again with uname -rm: 3.2.0-54-generic-pae i686

fine, then i installed ndiswrapper like described here: http://wiki.ubuntuusers.de/WLAN/NdisWrapper and i also tried this tutorial: http://www.ubuntufreunde.de/forum/500/netgear_wg111v2.html?s=4fa84183b98e26a805bf4b96dd5b2a1d37aa3890 (german tutorials)

the ndiswrapper seems to run and to work as it should. i tried bind in the correct inf file from the cd (win98 driver) and this worked with both, code or with the wifi driver window.

the new driver seems to work but im not sure if it's really the new one or the stock driver.

i edited /etc/modprobe.d/blacklist and added "blacklist rtl8187"

i edited /etc/modules and added "ndiswrapper" (of course without brackets)

but now the wifi stick won't connect to my wlan. (every other wlan device in my network works just fine) i checked the wlan password and the savety method several times - no connection.

i don't know what to do now except throwing that damn stick out of my window.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.