Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every day Ubuntu 12.04 64-bit on my Alienware X51 Dell PC crashes. The kernel I am using is 3.2.0-41-generic.

I have a python application running which downloads and uploads in the official hours. Every single day it crashes with this screen. I am unable to access it remotely, I can't ssh to it, nor can I do anything unless I go myself onsite and power off and power on the system.

Can anyone please advise how to get rid of this daily nightmare crashes?

enter image description here

EDIT:

# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)


# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.2 LTS
Release:    12.04
Codename:   precise


# uname -a
Linux e700second 3.2.0-41-generic #66-Ubuntu SMP Thu Apr 25 03:27:11 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

# dpkg -l | grep xserver-xorg-video
ii  xserver-xorg-video-all-lts-quantal           1:7.7+1ubuntu4~precise1                          X.Org X server -- output driver metapackage
ii  xserver-xorg-video-ati-lts-quantal           1:6.99.99~gitf772-0ubuntu1~precise2 X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-cirrus-lts-quantal        1:1.5.1-0ubuntu2~precise1                        X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-fbdev-lts-quantal         1:0.4.3-0ubuntu1~precise1                        X.Org X server -- fbdev display driver
ii  xserver-xorg-video-intel-lts-quantal         2:2.20.9-0ubuntu2~precise2                       X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-mach64-lts-quantal        6.9.3-0ubuntu1~precise2                          X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga-lts-quantal           1:1.6.2-0ubuntu1~precise2                        X.Org X server -- MGA display driver
ii  xserver-xorg-video-modesetting-lts-quantal   0.5.0-0ubuntu1~precise2                          X.Org X server -- Generic modesetting driver
ii  xserver-xorg-video-neomagic-lts-quantal      1:1.2.7-0ubuntu1~precise1                        X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nouveau-lts-quantal       1:1.0.2-0ubuntu3~precise2                        X.Org X server -- Nouveau display driver
ii  xserver-xorg-video-openchrome-lts-quantal    1:0.3.1-0ubuntu1~precise2                        X.Org X server -- VIA display driver
ii  xserver-xorg-video-r128-lts-quantal          6.9.1-0ubuntu1~precise2                          X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon-lts-quantal        1:6.99.99~gitf772-0ubuntu1~precise2 X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-s3-lts-quantal            1:0.6.5-0ubuntu1~precise1                        X.Org X server -- legacy S3 display driver
ii  xserver-xorg-video-savage-lts-quantal        1:2.3.6-0ubuntu1~precise1                        X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion-lts-quantal 1:1.7.7-0ubuntu1~precise1                        X.Org X server -- SiliconMotion display driver
ii  xserver-xorg-video-sis-lts-quantal           1:0.10.7-0ubuntu1~precise2                       X.Org X server -- SiS display driver
ii  xserver-xorg-video-sisusb-lts-quantal        1:0.9.6-0ubuntu1~precise1                        X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx-lts-quantal          1:1.4.5-0ubuntu1~precise2                        X.Org X server -- tdfx display driver
ii  xserver-xorg-video-trident-lts-quantal       1:1.3.6-0ubuntu2~precise1                        X.Org X server -- Trident display driver
ii  xserver-xorg-video-vesa-lts-quantal          1:2.3.2-0ubuntu1~precise1                        X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware-lts-quantal        1:12.0.2+git.e5ac80d8-0ubuntu1~precise2          X.Org X server -- VMware display driver

EDIT 1:

#!/bin/bash
export DISPLAY=:0.0
sudo -s

### Repository update
software-properties-gtk
apt-get update

### Kernel update
apt-get install linux-generic-lts-raring linux-headers-3.8.0-30 linux-headers-3.8.0-30-generic linux-headers-generic-lts-raring linux-image-3.8.0-30-generic linux-image-generic-lts-raring
update-grub

### Graphics update
apt-get install libgl1-mesa-dri-lts-raring libxatracker1-lts-raring xserver-xorg-core-lts-raring xserver-xorg-input-all-lts-raring xserver-xorg-input-evdev-lts-raring xserver-xorg-input-mouse-lts-raring xserver-xorg-input-synaptics-lts-raring xserver-xorg-input-vmmouse-lts-raring xserver-xorg-input-wacom-lts-raring xserver-xorg-lts-raring xserver-xorg-video-all-lts-raring xserver-xorg-video-ati-lts-raring xserver-xorg-video-cirrus-lts-raring xserver-xorg-video-fbdev-lts-raring xserver-xorg-video-intel-lts-raring xserver-xorg-video-mach64-lts-raring xserver-xorg-video-mga-lts-raring xserver-xorg-video-modesetting-lts-raring xserver-xorg-video-neomagic-lts-raring xserver-xorg-video-nouveau-lts-raring xserver-xorg-video-openchrome-lts-raring xserver-xorg-video-r128-lts-raring xserver-xorg-video-radeon-lts-raring xserver-xorg-video-s3-lts-raring xserver-xorg-video-savage-lts-raring xserver-xorg-video-siliconmotion-lts-raring xserver-xorg-video-sis-lts-raring xserver-xorg-video-sisusb-lts-raring xserver-xorg-video-tdfx-lts-raring xserver-xorg-video-trident-lts-raring xserver-xorg-video-vesa-lts-raring xserver-xorg-video-vmware-lts-raring libxrandr-ltsq2 x11-xserver-utils-lts-raring xserver-common-lts-raring
apt-get install --install-recommends xserver-xorg-lts-raring

### Tune
sudo apt-get autoremove
sudo apt-get autoclean
sudo dpkg-reconfigure -a # display nonthing, also show no error
sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}' | grep "^xserver" | tr '\n' ' ') # /usr/sbin/dpkg-reconfigure: xserver-common-lts-quantal is broken or not fully installed

update-initramfs -u
shutdown -r now

EDIT 2: second crash shot after applying the changes

enter image description here

EDIT 3: third crash shot after applying changes

enter image description here

share|improve this question
1  
Edit your question and please reply the output of these commands: sudo lspci | grep VGA , sudo lsb_release -a , sudo uname -aand sudo dpkg -l | grep xserver-xorg-video –  Saurav Kumar Oct 4 '13 at 6:12
    
Please see EDIT above. –  YumYumYum Oct 4 '13 at 6:16
1  
Ok, got it.. Your output is what I was expecting.. :) Please give me some time to post my answer.. –  Saurav Kumar Oct 4 '13 at 6:20

1 Answer 1

up vote 4 down vote accepted

Follow these steps precisely!

  1. Run following command in terminal and tick all check boxes under Ubuntu Software and Updates tabs. If already ticked then leave it.

    sudo software-properties-gtk
    

    then update your repository:

    sudo apt-get update
    
  2. Install Linux Kernel 3.8.0 by selecting following packages in Synaptic:

    linux-generic-lts-raring
    linux-headers-3.8.0-30
    linux-headers-3.8.0-30-generic
    linux-headers-generic-lts-raring
    linux-image-3.8.0-30-generic
    linux-image-generic-lts-raring
    

    You can also install Kernel 3.8.x by executing the following command:

    sudo apt-get install linux-generic-lts-raring linux-headers-3.8.0-30 linux-headers-3.8.0-30-generic linux-headers-generic-lts-raring linux-image-3.8.0-30-generic linux-image-generic-lts-raring
    

    Once installed, execute following command to update-grub and reboot your system (be sure to select Kernel 3.8.0.30 from your grub menu):

    sudo update-grub && sudo reboot
    

    Before trying the 3rd step, I just want you to try the 4th step. If it fixes your problem then there is no need to install the latest Xserver-Xorg packages, so you can skip the 3rd step.

  3. Install all -lts-raring packages for Xserver-Xorg using following the command:

    sudo apt-get install libgl1-mesa-dri-lts-raring libxatracker1-lts-raring xserver-xorg-core-lts-raring xserver-xorg-input-all-lts-raring xserver-xorg-input-evdev-lts-raring xserver-xorg-input-mouse-lts-raring xserver-xorg-input-synaptics-lts-raring xserver-xorg-input-vmmouse-lts-raring xserver-xorg-input-wacom-lts-raring xserver-xorg-lts-raring xserver-xorg-video-all-lts-raring xserver-xorg-video-ati-lts-raring xserver-xorg-video-cirrus-lts-raring xserver-xorg-video-fbdev-lts-raring xserver-xorg-video-intel-lts-raring xserver-xorg-video-mach64-lts-raring xserver-xorg-video-mga-lts-raring xserver-xorg-video-modesetting-lts-raring xserver-xorg-video-neomagic-lts-raring xserver-xorg-video-nouveau-lts-raring xserver-xorg-video-openchrome-lts-raring xserver-xorg-video-r128-lts-raring xserver-xorg-video-radeon-lts-raring xserver-xorg-video-s3-lts-raring xserver-xorg-video-savage-lts-raring xserver-xorg-video-siliconmotion-lts-raring xserver-xorg-video-sis-lts-raring xserver-xorg-video-sisusb-lts-raring xserver-xorg-video-tdfx-lts-raring xserver-xorg-video-trident-lts-raring xserver-xorg-video-vesa-lts-raring xserver-xorg-video-vmware-lts-raring libxrandr-ltsq2 x11-xserver-utils-lts-raring xserver-common-lts-raring
    

    Why this list is so long? Because it ensures, that you install all the lts-raring packages for xserver-xorg. I recommend you to copy and paste it in a terminal. It will remove already installed Xserver-Xorg packages, which were meant for previous kernel. So press y when it prompts to remove such packages. Run this command to ensure you installed all:

    sudo apt-get install --install-recommends xserver-xorg-lts-raring
    

    Again restart your system.

  4. Now execute the following commands:

    sudo apt-get autoremove
    sudo apt-get autoclean
    sudo dpkg-reconfigure -a
    sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}' | grep "^xserver" | tr '\n' ' ')
    

    If the last step shows some errors, then execute these commands sudo apt-get -f install, sudo apt-get --purge remove, sudo apt-get autoremove && sudo apt-get autoclean.

    Then again, try to run the command that gave you the error. If it still gives you the same error then replace that command with this one: sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}' | grep 'lts-raring' | tr '\n' ' ').

    Then continue to next command:

    sudo update-initramfs -u
    

    Then restart your system again:

    sudo reboot
    
  5. After rebooting your system, everything should work great.

A short description of all steps mentioned above:

1st Step ensures that you'll able to download lts-raring packages.

In 2nd step you are installing a good stable kernel for your system, you are using so old kernel: 3.2.x.

3rd Step will install Xserver-Xorg packages including graphics card driver which is best supported by Kernel 3.8.0

4th Step is used to re-configure the packages installed in your system to latest kernel just you installed.

It is not that much tough, I did it without any problem. And my system works great now! If you get any problem or error at any particular step, just reply mentioning that command with the error. I'll be waiting for your reply..

share|improve this answer
1  
Execute sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}' | grep "^xserver" | tr '\n' ' ') after executing these commands : 1.sudo apt-get autoremove, 2.sudo apt-get autoclean, 3.sudo apt-get --purge remove and 4.sudo dpkg --configure -a. Why it was showing error, because your xserver-xorg::lts-quantal was not removed completely. After step 4. execute this: sudo update-initramfs -u and restart. If still it shows some error, I've mentioned alternate way already in my answer.. :) –  Saurav Kumar Oct 4 '13 at 7:25
1  
And I don't know why sudo dpkg-reconfigure -a was not successful. Actually it takes some time around 1 to 3 minutes but without giving any message it executes and terminates successfully. It means that you have some residual packages that you can remove using Synaptic Package Manager –  Saurav Kumar Oct 4 '13 at 7:32
1  
Pretty strange..!! It is so difficult to get the crash window. One possible cause is the python script which updates your system. Try to disable that script and execute sudo software-properties-gtk and uncheck all the check-boxes under Updates and Other Software tabs, then execute sudo apt-get udpate, sudo apt-get autoremove && sudo apt-get autoclean and sudo apt-get -f install. Hope it helps you.. Reply.. –  Saurav Kumar Oct 4 '13 at 9:57
    
Saurav Kumar, please do NOT post the exact same answer on multiple questions. If the same answer is applicable for more than one question, then the right call of action is to flag the question as a duplicate of another. –  jokerdino Oct 4 '13 at 16:21
1  
@YumYumYum: Can you provide some more information like exactly when you system crashes? Does your system crash when you run some programs or do something else? –  Saurav Kumar Oct 4 '13 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.