Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

update:

With help from Canonical I was able to figure out something. The maas-import-pxe-files is getting stuck when downloading ephemeral images from ubuntu. I isolated the following:

wget -v xhttps://maas.ubuntu.com/images/query/precise/ephemeral/released-dl.current.txt -O /tmp/aaa.tmp

--2013-10-04 17:12:57-- https://maas.ubuntu.com/images/query/precise/ephemeral/released-dl.current.txt

Resolving maas.ubuntu.com (maas.ubuntu.com)... 91.189.90.19, 91.189.89.122 Connecting to maas.ubuntu.com (maas.ubuntu.com)|91.189.90.19|:443... failed: Connection timed out.

Connecting to maas.ubuntu.com (maas.ubuntu.com)|91.189.89.122|:443... failed: Connection timed out.

Despite the fact that I can telnet www.google.com 80, I can't wget. This is happening because my lab has a proxy. to work around this I had to

export http_proxy= proxy addr

export https_proxy= proxy addr

After that, note that

sudo maas-import-pxe-files

still doesn't work, but

sudo bash maas-import-pxe-files

does.

I'm not sure yet whether this will also fix the problem reported in the MaaS GUI, but will update as soon as the install is complete.

Original question

I've setup MAAS with region and cluster controller in same node. I can log into the GUI, and was able to create the superuser. There are two problems, which might be manifestation of the same issue.

1) The yellow bar on the page is now showing this message:

The region controller does not know whether any boot images have been imported yet.  
If this message does not disappear in 5 minutes, there may be a communication problem between the region worker process and the region controller.  
Check the region worker's logs for signs that it was unable to report to the MAAS API.  

2) When running:

sudo maas-import-pxe-files  

I get this output:

$ sudo /usr/sbin/maas-import-pxe-files
Downloading to temporary location /tmp/tmp.rITlDMoaQl.
/tmp/tmp.rITlDMoaQl /var/log/maas
2013-10-03 11:14:46 URL:xhttp://archive.ubuntu.com/ubuntu//dists/precise/main/installer-amd64/current/images/netboot/ubuntu-installer/amd64//linux [4965840/4965840] -> "linux" > [1]
2013-10-03 11:14:48 URL:xhttp://archive.ubuntu.com/ubuntu//dists/precise/main/installer-> amd64/current/images/netboot/ubuntu-installer/amd64//initrd.gz [17446386/17446386] -> "initrd.gz" [1]
2013-10-03 11:14:49 URL:xhttp://archive.ubuntu.com/ubuntu//dists/quantal/main/installer-> amd64/current/images/netboot/ubuntu-installer/amd64//linux [5130968/5130968] -> "linux" > [1]
2013-10-03 11:14:51 URL:xhttp://archive.ubuntu.com/ubuntu//dists/quantal/main/installer-> amd64/current/images/netboot/ubuntu-installer/amd64//initrd.gz [18668122/18668122] -> > > "initrd.gz" [1]
2013-10-03 11:14:52 URL:xhttp://archive.ubuntu.com/ubuntu//dists/precise/main/installer-> i386/current/images/netboot/ubuntu-installer/i386//linux [5015840/5015840] -> "linux" [1]
2013-10-03 11:14:54 URL:xhttp://archive.ubuntu.com/ubuntu//dists/precise/main/installer-i386/current/images/netboot/ubuntu-installer/i386//initrd.gz [15977428/15977428] -> "initrd.gz" [1]
2013-10-03 11:14:55 URL:xhttp://archive.ubuntu.com/ubuntu//dists/quantal/main/installer-i386/current/images/netboot/ubuntu-installer/i386//linux [5171760/5171760] -> "linux" [1]
2013-10-03 11:14:57 URL:xhttp://archive.ubuntu.com/ubuntu//dists/quantal/main/installer-i386/current/images/netboot/ubuntu-installer/i386//initrd.gz [17086667/17086667] -> "initrd.gz" [1]
2013-10-03 11:14:58 URL:xhttp://ports.ubuntu.com/ubuntu-ports//dists/precise-updates/main/installer-armhf/current/images/highbank/netboot//vmlinuz [2978672/2978672] -"vmlinuz" [1]
2013-10-03 11:14:58 URL:xhttp://ports.ubuntu.com/ubuntu-ports//dists/precise-updates/main/installer-armhf/current/images/highbank/netboot//initrd.gz [4958070/4958070] -> "initrd.gz" [1]
2013-10-03 11:14:59 URL:xhttp://ports.ubuntu.com/ubuntu-ports//dists/quantal/main/installer-armhf/current/images/highbank/netboot//vmlinuz [3738504/3738504] -> "vmlinuz" [1]
2013-10-03 11:15:00 URL:xhttp://ports.ubuntu.com/ubuntu-ports//dists/quantal/main/installer-armhf/current/images/highbank/netboot//initrd.gz [6213909/6213909] -> "initrd.gz" [1]

/var/log/maas

( I had to prepend an 'x' in front of http in the posting because I'm not allowed to post more than two links)

The command stay stuck at this point without returning the prompt. Note that:

uname -a  

Linux myhost 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux  

I did find bug 1067558 and 1070318 but I can't figure out how to go past this.

Any help is appreciated.

share|improve this question

2 Answers 2

On Ubuntu Server 14.04

What worked for me on 14.04 was:

1) Configure a static address for the network adapter in /etc/network/interfaces

# Example configuration
auto eth0
iface eth0 inet static
        address 192.168.0.2
        network 192.168.0.0
        netmask 255.255.255.0
        broadcast 192.168.0.255
        gateway 192.168.0.1

2) Check internet access by pinging an external host, e.g. ping google.com.
The entry gateway 192.168.0.1 is essential, as it will establish a route, like sudo route add default gw 192.168.0.1

3) Reconfigure MAAS to that static address and import PXE images: How to change the MaaS server ip address?

sudo dpkg-reconfigure maas-cluster-controller
sudo dpkg-reconfigure maas-region-controller
  • Delete 'Cluster master' (will be recreated)

4) Import PXE images

sudo maas-import-pxe-files
share|improve this answer

Can you try adding the lines export http_proxy= proxy addr and export https_proxy= proxy addr to /etc/environment and rebooting and see if that does it? I think sudo might not be passing on the proxy settings unless you use the sudo bash command you mentioned.

How do I configure proxies in Ubuntu Server or Minimal (CLI) Ubuntu?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.