Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All right folks, I have another very basic question. Please bear with me.

I'm following the instructions at the following website to download and configure Hadoop on my computer.

http://www.michael-noll.com/tutorials/running-hadoop-on-ubuntu-linux-single-node-cluster/

I'm at the final SSH section, when I use the localhost command. When I run the following code, I get an error message.

hadoop@amathew-Dimension-3000:~$ cat $HOME/.ssh/id_rsa.pub >> $HOME/.ssh/authorized_keys
hadoop@amathew-Dimension-3000:~$ ssh localhost
ssh: connect to host localhost port 22: Connection refused

Here's some other information which might be relevant.

hadoop@amathew-Dimension-3000:~$ ssh -vvv localhost
OpenSSH_5.5p1 Debian-4ubuntu5, OpenSSL 0.9.8o 01 Jun 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to localhost [::1] port 22.
debug1: connect to address ::1 port 22: Connection refused
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: connect to address 127.0.0.1 port 22: Connection refused
ssh: connect to host localhost port 22: Connection refused

Can anyone help?

Once again, thanks for helping the newbie who just can't figure things out yet.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

It seems to me that your SSH process is not running. Therefore there is no software which accepts connections on that port. You can check it by:

sudo service ssh status

or

sudo /etc/init.d/ssh status

The script should output something like ssh start/running, process 1234 if SSH is running. If not, you'll see ssh stop/waiting. I suspect you'll get the last message. If this is the case, you just should start your SSH daemon by:

sudo service ssh start

Furthermore you should have a look in you sshd_config and in /etc/default/ssh if there are some "strange" options.

share|improve this answer
    
Turns out I didn't have an openSSH client installed. I installed it and reran the commands and things are fixed. –  ATMathew Apr 15 '11 at 22:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.