Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot get nVidia drivers to load on my Lenovo Y510p. It ends up in either of 2 different states, either nothing loads, and I'm stuck in runlevel3, or I get a super low resolution desktop. I have tried every tutorial I could find (though most say the same thing)

If anyone has any insight, please help me out. I'm out of options.

share|improve this question
    
Please add to your question an overview of the things you tried ("every tutorial I could find" provides no information to most readers, nor does the fact that most say the same thing). For instance, did you try the Nvidia drivers from their site? –  zwets Oct 3 '13 at 12:42
    
@MatthewColeman - What nvidia-chipset is it exactly ? - in case of CUDA (sometimes with Optimus) then this solution here might help : askubuntu.com/questions/311151/… –  dschinn1001 Oct 4 '13 at 11:18
2  
I know it's not a solution but I've been able to use the Nvidia drivers successfully on Ubuntu 13.10 with nvidia-319. Nevertheless my current setup is with Bumblebee. –  Anton Petrov Nov 1 '13 at 16:34

1 Answer 1

Your laptop has an Optimus NVIDIA card. I suspect that installing Bumblebee is the ticket.

1) Add the repository to get new nvidia drivers:

apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update

2) install the latest drivers:

sudo apt-get install nvidia-331 nvidia-settings-331

Install Bumblebee (as explained here)

1) Add the Bumblebee PPA:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update

2) Install Bumblebee and its dependencies:

sudo apt-get install bumblebee bumblebee-nvidia virtualgl linux-headers-generic

Configure bumblebee to use your new driver:

1) Open the config file:

sudo gedit /etc/bumblebee/bumblebee.conf

2) Change the Driver, KernelDriver, Librarypath, and XorgModulePath like so:

Driver=nvidia

KernelDriver=nvidia-331

LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331

XorgModulePath=/usr/lib/nvidia-331-updates/xorg,/usr/lib/xorg/modules

Restart.

EDIT2: Something to do if you can't use optirun (Bumblebee's method to invoke the Nvidia card)

Edit the bumblebee nvidia configuration:

sudo gedit /etc/bumblebee/xorg.conf.nvidia

Delete the "#" in front of "BusID ... "

EDIT: If it still doesn't work

You might need to change the parameters passed to the kernel. To test if this is the solution:

  1. When you get to grub, select Linux (but don't hit enter.)

  2. hit"e" on the keyboard

  3. add "acpi_osi=Linux" to the end of the line that begins with "linux /boot/ ..."

  4. Press F10 to boot.

If this works, you can make the change permanent by editing /etc/default/grub

  1. type "sudo gedit /etc/default/grub"
  2. edit the line with "GRUB_CMDLINE_LINUX_DEFAULT" so that it reads

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

  3. Save and quid gedit

  4. run "sudo update-grub"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.