Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two OS windows 7 and ubuntu. Oracle installer for linux stored in

/media/sonnet/Main/oracle/disk1/

and

/media/sonnet/Main/oracle/disk2/

here "Main" is an windows(ntfs) drive.

when I'm trying to start installing it is replying

./runInstaller : Permission Denied

I have tried

chmod -R 777 runInstaller

also the same result.

Thanks in advance for reply.

share|improve this question

2 Answers 2

So you want to install java? I am not sure why you want to do it from a windows directory. I also have a dual-boot, and Ubuntu does not play nice with it. I am not sure that this is what you want, but just install Java using these steps.

1.) If you’ve already installed OpenJDK in Ubuntu Software Center. Remove it by running this command:

sudo apt-get purge openjdk*

2.) To add the ppa, run:

sudo add-apt-repository ppa:webupd8team/java

Then update:

sudo apt-get update 3.) To install Oracle Java 8:

sudo apt-get install oracle-java8-installer

To install Oracle Java 7:

sudo apt-get install oracle-java7-installer

To install the Java 6:

sudo apt-get install oracle-java6-installer

If you are unsure which one I suggest java 7. Let me know if this solves your problem. Source: http://ubuntuhandbook.org/index.php/2013/07/install-oracle-java-6-7-8-on-ubuntu-13-10/

share|improve this answer

In your /etc/fstab how do you mount /media/sonnet/Main/oracle/ ? In other words, you should see some sort of line within /etc/fstab that may look like this:

/dev/sda$ /media/sonnet/Main/oracle    ntfs    defaults,umask=007,gid=XX  0       0

Where the $ in sda (or hda) represents the drive partition for your Windows drive and XX in the gid= represents the Group ID for 'sonnet'. the umask permissions are the allowed permissions for 'sonnet' when the drive is mounted.

In the example shown, the user and group have full read, write and execute permissions on the drive, while others are denied permission.

One other thing to note here in your statement:

chmod -R /runinstaller

This is incorrect, primarily because it would be looking for the runinstaller file on the root path. You have potentially made everything in root (/) world readable, writable and executable with that command. What you really wanted to do there was likely:

chown sonnet:sonnet /media/sonnet/Main/disk2/oracle/runinstaller

Then make the file executable by your user and group:

chmod 770 /media/sonnet/Main/disk2/oracle/runinstaller

Which should allow you to run that file (provided the partition is properly mounted) as user 'sonnet'.

Do HTH. Have a nice day. :)

share|improve this answer
    
As I'm new linux user, I don't know What is my group ID (gid), And my Windows(ntfs) partition name is "Main" and can you please let me know the sequential commands to install some thing stored in Windows Partition and/or pen drive? –  Sonnet Oct 3 '13 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.