Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

sometimes the xfce4-power-manager does not show up in the panel and it`s not working at all, and sometimes is working.

when it`s not working I have 2 solutions:

    • log out, and log in.
    • start system monitor and kill xfce4-power-manager, then start terminal and type:

    xfce4-power-manager --no-daemon

usually I use second solution, but to simplify the process I tried to write a shell script that restarts the xfce4-power-manager, with no success.

I cannot shut down the xfce4-power-manager from terminal.

xfce4-power-manager --restart 

-is not working

xfce4-power-manager --quit 

-is not working

I tried:

#!/bin/bash
PID=`pidof xfce4-power-manager`
kill $PID
xfce4-power-manager --no-daemon

-is not working.

If I type:

xfce4-power-manager --customize 

-an error window appears with:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

in the system monitor at Waiting Chanel says: futex_wait_queue_me.

Thank you

share|improve this question
    
I found an answer that may help, not tested yet: askubuntu.com/questions/129671/… 0 down vote I had this problem, i unchecked "Power Manager" from "Application Autostart" list in Settings -> Session and Startup and added another application with this command xfce4-power-manager --no-daemon then i have not have this problem yet. –  Botond Vajna Oct 3 '13 at 10:38

1 Answer 1

xfce4-power-manager not started, applet not visible

Delete > Desktop configuration file:
/etc/xdg/autostart/xfce4-power-manager.desktop

.

Settings Manager / Session and Startup / Startup Applications

Item disabled:
Energy Management (power Management Xfce environment)

New item enabled with new command:

Mame: Xfce Power Manager (For example-Your name)

Description: Power manager startup

Command: xfce4-power-manager --no-daemon

http://ubuntuset.url.ph/power_manager.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.