Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a TP-Link TL-WR702N wireless router (see http://www.tp-link.com.de/products/details/?model=TL-WR702N) and an ethernet plug in the wall. If I connect the (single) LAN/WAN port to the ethernet plug, I can access the internet with my smartphone (which makes me believe this is an Ubuntu problem), so the wireless connection works. However, I cannot access it with my Lenovo Thinkpad running Ubuntu 13.04 (note: the notebook connects to the wireless network, but cannot access the internet; a wired connection to the ethernet wall plug directly works fine though). I experimented quite a bit (in System Settings -> Network -> Wireless -> TP-LINK_xxxxxx -> Settings), but it never worked. As default, the wireless router is in "AP mode" which should be fine (since I couldn't access the management website of the router, I reset it, so this should be fine). Also note that I recently used the wireless router in "Router mode" (connected to a cable router) and I had access both from the smartphone and the notebook. What could be the problem?

If I connect wirelessly to TP-LINK_xxxxxx (IPv4: 'Automatic (DHCP)'), here is what I see in System Settings -> Network -> Wireless -> TP-LINK_xxxxxx -> Settings:

Strength Excellent
Link speed 72 Mb/s
IP Address
Default Router

In case this helps, this is what my smartphone shows:

IP Address
Subnet Mask
Search Domains glc

Here is some more information about the connection:


lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:134864 errors:0 dropped:0 overruns:0 frame:0
          TX packets:134864 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:13397930 (13.3 MB)  TX bytes:13397930 (13.3 MB)

wlan0     Link encap:Ethernet  HWaddr 84:3a:4b:0b:e9:d0  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::863a:4bff:fe0b:e9d0/64 Scope:Link
          RX packets:113964 errors:0 dropped:1701 overruns:0 frame:0
          TX packets:34498 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:23204505 (23.2 MB)  TX bytes:6682743 (6.6 MB)

cat /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
search glc

nm-tool | grep DNS


route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 wlan0     U     1000   0        0 wlan0   U     9      0        0 wlan0


eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"TP-LINK_44052E"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: F8:1A:67:44:05:2E   
          Bit Rate=72.2 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-24 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:32  Invalid misc:46   Missed beacon:0

cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

sudo lshw -C network

[sudo] password for ...: 
       description: Wireless interface
       product: Centrino Advanced-N 6205 [Taylor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 96
       serial: 84:3a:4b:0b:e9:d0
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.8.0-22-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:45 memory:f0c00000-f0c01fff
       description: Ethernet interface
       physical id: 2
       logical name: eth0
       serial: 00:b5:6d:00:8b:4a
       size: 10Mbit/s
       capacity: 100Mbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=asix driverversion=22-Dec-2011 duplex=half firmware=ASIX AX88772 USB 2.0 Ethernet link=no multicast=yes port=MII speed=10Mbit/s
share|improve this question
Your Router IP and DNS is on on the computer while the phone has Is the computer set on static? Try changing in to use the same IP(as mentioned) as used by the phone. –  Pieter Oct 3 '13 at 7:07
Thanks for helping, Pieter. This was an old (static) setup, I tried. With 'Automatic' I indeed get the same setup as on the phone. I corrected it in the original post (still no internet connection). I am wondering whether the 'Search Domains' matters (?) and how one would set this up in Ubuntu. Let me know if you need output of commands like 'ifconfig' or 'iwconfig' –  Marius Hofert Oct 3 '13 at 7:16
Try to complete remove the connection from the network panel (top right in the global menu)->Edit Connections and then re add/create it. I have never seen the Search Domain before - it seems to be an Apple setting. –  Pieter Oct 3 '13 at 7:32
I did that (just another time). Ubuntu directly finds the wireless network, connects to it, but I cannot access any website. –  Marius Hofert Oct 3 '13 at 7:45
Can you access the router's WebUI or ping it using ping -c 1 If it can ping the router then ping to see where the connection is lost/broken. –  Pieter Oct 3 '13 at 7:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.