Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I installed the compat driver to get my RealTek wireless card working. Everyting was fine until I rebooted my laptop this morning. And no wireless connections show up in Network Manager.

lshw -C network looks good

  *-network
       description: Wireless interface
       product: RTL8723AE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial: 48:d2:24:28:70:4d
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723ae driverversion=3.2.0-54-generic firmware=N/A latency=0 multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 ioport:d000(size=256) memory:f7900000-f7903fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.2
       bus info: pci@0000:04:00.2
       logical name: eth0
       version: 0a
       serial: 00:90:f5:ea:e4:59
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.037.00-NAPI duplex=half latency=0 multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:42 ioport:c000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff

iwconfig is fine as well

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 76:F6:73:EB:45:1E   
          Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

I wouldn't have posted here if Google-ing had solved my problem. Things I have tried

service network-manager restart
ifconfig wlan0 up
/ect/init.d/networking restart
gedit /etc/NetworkManager/NetworkManager.conf and set managed=false to true
gedit /etc/network/interfaces and everything looks good ( I didn't change it, just checked that wlan0 is not listed there)
rmmod rtl8723ae
modprobe rtl8723ae

But nothing works.

I guess something was turned on during driver installation, but the system failed to turn it on again during booting. Can anyone help me? Or else I have to live in a world without internet connection(maybe better, huh?).

Some log message

$ dmesg | grep -i rtl
[   18.775375] rtl8723ae 0000:03:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[   18.775384] rtl8723ae 0000:03:00.0: setting latency timer to 64
[   18.790268] rtl8723ae: Using firmware rtlwifi/rtl8723fw_B.bin
[   19.079022] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   19.079268] rtlwifi: wireless switch is on

iwlist scan says that no wireless connection is found. nmcli dev and nmcli dev wifi list give similar results ( the device is OK, but no connections found).

EDIT:

This is the first time I post on askubuntu, and I feel really glad to receive help from chili555 and Ramchandra Apte. But let me finish my story first.

I reboot my system to Windows 8 to make sure that the wireless card is OK. After that, I switch to Ubuntu, and run iwlist scan, and feel really surprised to see tons of output coming from the terminal. Now everything works out of the box again!

I remembered that when I was trying to suspend my laptop the night I installed the compat driver for the first time, it took longer than usual, so I long-pressed the power button. Since then, the laptop would fail to recover if I closed its lid to suspend it. And the wireless stopped working the morning after that.

So the real problem may have little to do with the wireless driver. I guess an internal switch in the hardware was toggled during halting, so the card ceased to scan for connections. However, the Windows driver is clever (or lucky) enough to re-enable the card, and things work out.

I cannot reproduce the problem now so some of the logs are incomplete. However, the problem is fixed anyway. And I witnessed a sharp increase in my productivity during the nights when my laptop could not connect to wifi.

Thank you for your time. Really appreciate your help.

share|improve this question
    
Are there any clues in the message logs? dmesg | grep -i rtl –  chili555 Oct 3 '13 at 13:32
    
However, I think dmesg | grep -i wl gives more interesting results. –  user2341715 Oct 4 '13 at 1:25
    
Why is a Broadcom driver, wl loaded for your product: RTL8723AE PCIe Wireless Network Adapter; vendor: Realtek Semiconductor Co., Ltd. ?? –  chili555 Oct 4 '13 at 2:04
    
You are right. I've removed the Broadcom driver, and wl no longer shows up. However, the problem remains. See the edit. –  user2341715 Oct 5 '13 at 14:54
    
What edits did you do to /etc/network/interfaces? Please post. Does it scan? sudo iwlist wlan0 scan –  chili555 Oct 5 '13 at 16:07
show 1 more comment

1 Answer

up vote 0 down vote accepted

It seems everything is OK with your configuration looking at the output. It's quite possible that Network Manager or the frontend to that is broken, but the underlying things are still working. Try running sudo iwlist scanning to view the list of wireless networks and post the output of that. Also post the output of nmcli dev and nmcli dev wifi list. I'll improve this answer as responses containing more information arrive.

Or else I have to live in a world without internet connection(maybe better, huh?).

You might be interested in this article

share|improve this answer
    
It seems that the frontend and the driver are all OK, but the underlying hardware is broken. Thank you for you answer and the link to that article. –  user2341715 Oct 6 '13 at 4:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.