Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I need this, because sometimes the Gnome Shell "forgot" all my extensions configurations after a normal reboot/shutdown. And I'don't want reinstall entire system because this.

So I want a script or a command to enable then all during the my session startup (putting in gnome-session-properties) or even a fix for this problem.

I'm using Ubuntu Gnome 13.04 on Gnome Shell 3.8.3 (downgrade, now on v3.6.3.1)

Output of find ~/ \! -user $USER -print:

/home/mediacenter/.cache/dconf
find: `/home/mediacenter/.cache/dconf': Permission denied
/home/mediacenter/.gvfs
find: `/home/mediacenter/.gvfs': Permission denied
share|improve this question

marked as duplicate by Braiam, guntbert, Luis Alvarado Dec 9 '13 at 0:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Sorry, what? If you are using the PPA, that is understandable. Since the PPA is unstable you should remove it and stick with the version in the Ubuntu repositories. The PPA could have unforeseen problems that would mess up your preferences. I'm using Gnome 3.6 without issues of this type. –  Braiam Oct 2 '13 at 21:29
    
I make a downgrade to Gnome 3.6 and don't solve the problem of 'forgot' configurations. But thanks for the enlightening, Braiam. –  Maxwel Leite Oct 5 '13 at 21:09
    
Sorry to hear that. Can you provide the output of find ~/ \! -user $USER -print, if any? Edit your question if the output is positive. –  Braiam Oct 5 '13 at 21:25
    
Never had that problem with my Gnome-shell 3.8 (ubuntu 13.04 x64), but two days ago I upgrade to Ubuntu 13.10 RC and Gnome-Shell 3.10 and now I have this problem that drives me crazy... –  JoZ3 Oct 16 '13 at 14:17

2 Answers 2

up vote 4 down vote accepted

To activate/enable all extensions every time at startup:

  1. Create a folder for your own scripts:

    mkdir ~/bin

  2. Create a script file: gnome-shell-enable-all-extensions.sh:

    nano ~/bin/gnome-shell-enable-all-extensions.sh

    With contents:

    #!/bin/bash sleep 2s # just in case cd ~/.local/share/gnome-shell/extensions array=($(ls -l --time-style=long-iso | egrep '^d' | awk '{print $8}')) # get only the folder names from current path ext_list=$(printf "'%s'," "${array[@]}") # rebuild the string ext_list=${ext_list%,} # Remove the final character of the variable gsettings set org.gnome.shell enabled-extensions "[${ext_list}]"

  3. Setting up permissions for the script file:

    chmod +x ~/bin/gnome-shell-enable-all-extensions.sh

  4. At last, puts the command in startup gnome-session-properties:

    /home/YOUR-USERNAME/bin/gnome-shell-enable-all-extensions.sh

share|improve this answer
    
I still believe that is not a normal situation and your preferences shouldn't be forgotten... but ok. –  Braiam Oct 5 '13 at 21:49
2  
Thanks for this solution, there is already a bug report about this here - bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1236749 –  JoZ3 Oct 16 '13 at 22:13

I know it's a bit late but I implemented a solution script in python if the one above don't satisfy you.

https://github.com/loric-/enableGnomeExtensions.py

Hope that the problem will be fixed soon by the way.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.