Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Toshiba laptop has an nVidia graphics card which is not supported in Ubuntu, and there is no Entry in "Additional Drivers"

I tried installing the driver from the nVidia website (Which does have a Linux 64bit version) but nothing happens zwhen I click the .run file (I have made it executable).

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

The file should be executed in the terminal, not through the file browser. Please make a backup (preferably using disk-cloning software like Clonezilla before proceeding, better safe than sorry. I have had bad experience with the proprietary drivers because my Optimus card is not supported.

  1. Blacklist the nouveau driver by editing the file /etc/modprobe.d/blacklist.conf as root and add the next lines:

    blacklist nouveau
    blacklist nvidiafb
    

    Alternatively, open a terminal and run the next command:

    printf 'blacklist nouveau\nblacklist nvidiafb\n' | sudo tee /etc/modprobe.d/blacklist.conf
    
  2. Update the modules dependencies map and the initial ramdisk to remove the nouveau drivers by running the next commands in a terminal.

    sudo depmod -a
    sudo update-initramfs -u
    
  3. Reboot the machine, and before GRUB is booting, hold the Shift key to make the menu appear.
  4. Select the (recovery mode) entry.
  5. Choose root shell
  6. Assuming you've downloaded the file to /home/user/NVIDIA-Linux-x86_64-260.19.44.run, run the program:

    /home/user/NVIDIA-Linux-x86_64-260.19.44.run
    

    (root permissions is required because the program needs to write drivers and programs to privileged locations)

  7. Follow the on-screen instructions
share|improve this answer
    
Thanks! It tells me that I am using an X server so I can't install, even when I am using the terminal by typing ctrl+Alt+1 and not logged in graphically. How do I quit the X server? –  Calixte Apr 15 '11 at 16:16
    
@Calixte: even if you're not using the graphical server, it remains active in the background. Please make a backup before proceeding!. To make things easier, I would just reboot into recovery mode. You should have the file ready at some locatio. –  Lekensteyn Apr 15 '11 at 16:21
    
Thanks for the help. The installation failed however. Apparently, the Nouveau has to be disabled first, but there were no instructions on how to do that. –  Calixte Apr 15 '11 at 16:31
1  
@Calixte: updated the answer again! –  Lekensteyn Apr 15 '11 at 16:41
    
Everything works perfectly, but then I can't reboot: * starting load fallback graphics devices [fail] Thanks for all the help, your instructions are great –  Calixte Apr 15 '11 at 16:59
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.