Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using Ubuntu for two years now and had few actual problems. I have searched this site and tried various things to no effect. I will do my best to explain, and certainly include too much info as I have no idea what my problem really is. Please take answers to the 'for dummies'-level and I shall certainly do my best to understand!

So, I have this lovely acer TravelMate 5310 from around 07 that's causing a bit of a headache. It's Vista was removed and replaced with Ubuntu 11.?? some two years ago and was updated to the 12.04 LTS at some point before christmas. It has worked well except a problem with the network that's solved with a plug in reciever. All was just fine until I two days ago wanted to install the latest version, 13.04. I by accident installed 12.04LTS again and thought it won't matter. The problem with shutdown started after this, and we have finally arrived at the point of all this.

It won't shut down. I removed the 12 and installed the 13 last night thinking the problem might go away. It installed and updated and whent for a restart without problems but came to a halt at the purple screen.

I performed the hard shutdown(the press button method) and restarted. It boots up with ease and all is really well BUT it simply cannot shut down. It now hangs on a black screen with loads of white numbers, words and other such terminal-like things. So I push and hold shutdown to turn it off.

I tried the answer from my computer won't shut down. Then tried the acpi=off in terminal but nothing works. I have yet to try the command shutdown -h now but I now managed to hit ESC at the right time and go behind the first screen and see the next. I am sorry that I have no pictures to show you.

The processes that seems to fail are two:

*killing all remaining processes....                              [fail]  
modem-manager[953] : <info> Caught signal 15, shutting down...

then follows ok's on deactivating swaps, unmounting filesystems.
then:

*stopping remanining crypto discs...       [ok]  
*stopping early crypto discs...            [fail]  
Unmount:  /run/lock:  not mounted  
unmount:  /run/shm:  not mounted  
mount: / is busy  
  *will now halt  

And that is where it hangs..
I hope you are able to understand anything. I have no idea.

share|improve this question

closed as off-topic by bain, Mateo, Eric Carvalho, psusi, Radu Rădeanu Jul 14 at 0:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Mateo, Eric Carvalho, psusi, Radu Rădeanu
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Why does the title have 13.10 and the body have 13.04? –  user25656 Oct 1 '13 at 12:45
    
Check if doing sudo poweroff on a terminal helps. This is not a permanent solution, just a workaround, if it works! –  i08in Oct 1 '13 at 13:47
    
I don't know about poweroff, but I do shutdown -h now when I need to "force" a shutdown and works just fine. –  Jesse Oct 1 '13 at 13:53
    
If you are using Ubuntu 13.10 you should report it as a bug. –  Braiam Oct 2 '13 at 20:53

1 Answer 1

Try following the instructions from Shutdown does not power off computer

Type in terminal:

  1. sudo -i (to get a root shell, sudo gedit is not recommended)
  2. gedit /etc/default/grub
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
  4. Change this to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
  5. Save the file and close the file.
  6. Finally, in terminal: update-grub
  7. exit (to end the root shell)
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.