Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently installed scid from ubuntu repositorys. I've met with 2 problems.
1) After install ; there isn't any shortcut made to run program; so I have to either run it from console or make my own shortcut.My experience so far was that shortcut is made during install.
2) I can't change width of gui after starting it; only length.

share|improve this question
up vote 1 down vote accepted

1. Menu options aren't "shortcuts", they are based on special *.desktop files (that also specify the document types it can open and other information about an application). It seems like no *.desktop file is provided for scid (or it doesn't include the necessary info for a menu item) and as a result the menu system doesn't know about it.

If you want a menu item to be shown automaticly after the install, the best you can do is file a bug about it, and if you like to help you can also provide a working *.desktop file, or even better a debdiff, as an attachment to the bug report. Also, asking the upstream author to provide a *.desktop file would help for the future.

(If you want to know how to create a *.desktop file and/or a debdiff, maybe ask separate questions about that; that way they will be easier to find in the future.)

2. That sounds like a limitation that the program author is responsible for. You can try to contact the author and ask if he/she wants to change it (or why not).

share|improve this answer
+1 for information regarding how to: Contribute to a fix and for having to file a bug about missing menu item and for mentioning possibly making a new question for *.desktop files. I would also probably mention that you can create Menu Items using alacarte or System -> Preferences -> Main Menu as a short term fix. – Marco Ceppi Sep 3 '10 at 23:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.