Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently upgrade my 12.04 desktop installation to 12.10 and then to 13.04 hoping that my problems with VPN would disappear. I can't put my finger on when, but in 12.04, I just started noticing that the PPTP service was crashing every 2-5 minutes, making VPN essentially unusable. Finding nothing satisfying in the forums, I decided to be a little more bold and upgrade - both to check out the new version and hopefully have VPN automatically be repaired. By the way, it's been working great until just recently on 12.04 and it doesn't work at all now.

So, it's completely and inexplicably broken on 13.04. It seems that the pppd daemon is just gone. Hunting down how to reinstall it didn't yield much of anything. There were Launchpad bugs reported related to this but no resolution.

Here's my syslog when I try to connect. As you can see, it doesn't even start now:

Oct  1 15:07:20 Shuttle NetworkManager[1011]: <info> Starting VPN service 'pptp'...
Oct  1 15:07:20 Shuttle NetworkManager[1011]: <info> VPN service 'pptp' started (org.freedesktop.NetworkManager.pptp), PID 6436
Oct  1 15:07:20 Shuttle NetworkManager[1011]: <info> VPN service 'pptp' appeared; activating connections
Oct  1 15:07:20 Shuttle NetworkManager[1011]: <info> VPN plugin state changed: init (1)
Oct  1 15:07:20 Shuttle NetworkManager[1011]: <info> VPN plugin state changed: starting (3)
Oct  1 15:07:20 Shuttle NetworkManager[1011]: <info> VPN connection 'Strong PPTP' (Connect) reply received.
Oct  1 15:07:20 Shuttle NetworkManager[1011]: <warn> VPN connection 'Strong PPTP' failed to connect: 'Could not find the pppd binary.'.
Oct  1 15:07:20 Shuttle NetworkManager[1011]: <info> Policy set 'The 'Net' (eth0) as default for IPv4 routing and DNS.
Oct  1 15:07:20 Shuttle NetworkManager[1011]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
Oct  1 15:07:26 Shuttle NetworkManager[1011]: <info> VPN service 'pptp' disappeared

I'll do what it takes to get this working, but this seems so fundamental to the OS. Any ideas?

Why would this be so hard to repair?

share|improve this question

Update on this: After sleeping on this problem, I suddenly remembered a long forgotten friend: Synaptic Package Manager. So, I opened that up, removed everything related to PPTP, then reinstalled it. I then installed some extra stuff in the hopes that it would repair the pppd daemon: OpenVPN and the PPP daemon itself.

And, lo and behold, it worked! I've got to remember that next time!

share|improve this answer

I had the same problem when attempting to connect the VPN---'Could not find the pppd binary.'---perhaps related to an upgrade from Ubuntu 10.10 to 12.04. I fixed it by removing and reinstalling the PPP daemon using the Ubuntu Software Center. Removing the PPP daemon also forced removing network-manager-pptp, pppconfig, pppoeconf, and pptp-linux, so after reinstalling the PPP daemon, I had to re-install the first three of these (pptp-linux had been reinstalled automatically, apparently). After reinstalling, the VPN works as expected.

So, in my case I did not have to use Synaptic and I did not have to install OpenVPN.

share|improve this answer

From the software center, search for ppp and remove it / reinstall it. You can install everything form the terminal using this:

sudo apt-get install ppp network-manager-pptp pppconfig pppoeconf pptp-linux

This is a typical VPN Connection settings, from Connections, go to VPN Connections and add a new one/edit exiting or skip this if you had it setup: VPN Type: PPTP Gateway: user name: myuserid password: Active Directory Pass/LDAP, etc.. NT Domain: N/A , blank (not specified) Advanced: auth-methods: All Selected (will try all) Use Point to Point encryption MPPE: (checked) Allow BSD Data encryption (checked) Allow deflate data compression (checked) use TCP header compression (checked) Send PPP echo packets (unchecked)

Refer to this answer for a more graphical set of instructions.

This worked great for me, prior to that I would get the VPN plugin failed error.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.