Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
Error mounting /dev/sda2 at /run/media/Juno/Two: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda2" "/run/media/aunshi/Two"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sda2': Eingabe-/Ausgabefehler
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

The HDD is GPT formated large disk and the partition in question is the second one. Mounting was done simply by double-clicking on the drive. The disk is fine under windows. Can someone enlighten me? Thanks.

share|improve this question
1  
Did you read the error message and have you followed the instructions? –  Radu Rădeanu Sep 30 '13 at 20:15
    
yes I did. The NTFS is not inconsistent, it was freshly created and the hardware was checked (took 19 hours to run). AFAIU Gparted can handle GPT drives. The device is not a SoftRAID. Maybe I can't see the woods for the trees here, sorry if that's the case. –  Mike Oct 1 '13 at 19:28
    
What Windows version are you using? Windows 8 has a "fast startup" feature that turns its shutdown action into a suspend-to-disk action. The problem is that this leaves all mounted filesystems in an inconsistent state, so they'll either be corrupted or be damaged in another OS (such as Ubuntu). If you've got Windows 8, you should disable this feature immediately, as described here. –  Rod Smith Oct 1 '13 at 23:40
    
GParted can handle GPT just fine. –  Rod Smith Oct 1 '13 at 23:40
    
'using Windows 7, without suspend-to-ram or ~disk or any other such feature. It seems I forgot to mention that said hard disk was formated using Gparted. –  Mike Oct 7 '13 at 4:00

1 Answer 1

I just solved a similar problem. Hope this helps.

  1. Installed a new 2TB SATA disk on Windows Server 2012 R2, created a GPT partition and quick formatted it to NTFS, created test folder foo, shutdown, removed disk.
  2. Connected disk to ubuntu 12.04 LTS server. Created mountpoint /data2 with mkdir

  3. lshw -C disk (shows my 3rd disk, *-disk2 as /dev/sdc )

  4. fdisk -l (gives a warning about not liking GPT, and saying to use gparted)

  5. ls /dev/sdc* (shows partitions sdc, sd1, and sd2 !!!)

I only created 1 partition in Windows Server. The partition number was off by plus 1.

I tried,

mount -t ntfs /dev/sdc /data2
mount -t ntfs /dev/sdc1 /data2

and always got an error.

mount -t ntfs /dev/sdc2 /data2

Worked like a charm. foo was in /data2

Linux ubuntu101 3.2.0-54-generic #82-Ubuntu SMP Tue Sep 10 20:08:42 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.