Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to set a custom resolution in Ubuntu. my flat screen monitor is 1440x900 but this resolution is not listed under "displays" settings.

The only options available are 1920x1080(which i am using right now), 1280x720 and 720x576." Nvidia x server settings detects my display as a "CVTE TV 1920X1080 (DFP-1)". Nvidia x server settings does not allow me to set a custom "viewportout" as it comes back to default after applying settings.

In windows my display was not detected automatically, but all I had to do was set a custom resolution in nvidia control panel and it worked perfectly. I'm running ubuntu 13.04 with nvidia proprietary driver (for GTX 570). I have tried HDMI and dvi>vga connections and both don't list my resolution. is there a way to set a custom resolution in Ubuntu that is displayed properly?

description: VGA compatible controller product: GF110 [GeForce GTX 570 Rev. 2] vendor: NVIDIA Corporation physical id: 0 bus info: pci@0000:01:00.0 version: a1 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress vga_controller bus_master cap_list rom configuration: driver=nvidia latency=0 resources: irq:16 memory:f6000000-f6ffffff memory:e8000000-efffffff memory:f2000000-f3ffffff ioport:dc00(size=128) memory:f7d00000-f7d7ffff

share|improve this question
    
Listed at what? What thing you used to list the resolutions? xrandr or something from GUI? Your question is not completed. –  ZDroid Sep 30 '13 at 18:03
    
Is this a TV set rather than a real computer monitor? They are notorious for lieing about their resolution. –  psusi Sep 30 '13 at 18:35

1 Answer 1

This article explains how to add a custom resolution to Ubuntu. http://samuelmartin.wordpress.com/2012/05/29/enabling-resolutions-in-ubuntu-12-04-lubuntu-12-04/

And this thread on Ubuntu has two answers that will tell you how to add the resolution fairly easily

How to add display resolution fo an LCD in Ubuntu 12.04? xrandr problem

I recently replaced my screen with a new monitor screen for my laptop and it has 1400x900 resolution which Ubuntu used immediately with no problem. I am using Ubuntu 12.04 LTS

share|improve this answer
    
Please say the steps you used to do that! –  Philippe Gachoud Apr 8 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.