Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 12.04 at work and we have a proxy server. I would like to allow guests to use my computer on the guest account, but I cannot get the proxy settings to stay. Is there a way to set the proxy setting automatically at log-in for the guest account? The AskUbuntu question Change default guest session launcher applications? shows how to configure the launcher icons. Can I use this file to set a persistent proxy server setting? If so, how?

share|improve this question
up vote 1 down vote accepted

Most likely you can use the same approach as in the other question, provided that you figure out what the command is. In 12.04 I think it would be gconftool-2 rather than gsettings.

However, if you go to System Settings -> Network -> Network proxy, there is an "Apply system wide" button (at least in 13.04). Making the proxy settings system wide is possibly a simpler way to achieve what you want.

Another possibility: I wrote a tutorial about guest session customization. The tutorial was originally published at Ubuntu Forums, and there a user added a step-by-step guide showing an alternative method to customize guest sessions.

share|improve this answer
The "Apply system-wide" does not seem to apply to browsers in other accounts; it allows manual proxies to be used through apt-get and the software center ("Apply system-wide" does not work at all with automatic proxies). – HarlemSquirrel Oct 7 '13 at 23:38
@HarlemSquirrel: Ok, it's probably the Firefox proxy settings you need to change. I edited my answer by adding a third para that may be helpful to your situation. – Gunnar Hjalmarsson Oct 8 '13 at 21:29
Gunnar, for some reason my guest account now seems to work with my system-wide proxy set in Ubuntu 12.04 so thanks for the info! – HarlemSquirrel Mar 21 '14 at 12:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.