Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Now, before I begin, I would like to say that I am a fairly advanced user. I know how things work, and I troubleshoot. Therefore as such, I have deleted my profile, recreated it, tested new ones, deleted .mozilla, purged, reinstalled, checked about:config (and changing values which seem to contradict saving history), deleted Firefox and Xmarks, and even manually deleted the folders and remade them.

The .mozilla directory has ALL my user permissions. I made sure of this. Clearing history does NOT generate a new one. History is set to be remembered, and is NOT set to clear when Firefox closes. I have already checked.

If creating a new profile doesn't solve my issue, then how can places.sqlite be the problem (as is suggested over at Mozilla's Mozine/KB)? I've already deleted my Firefox profiles countless times and made countless more new ones, so I hardly doubt it's that now.

Main issue: I open Firefox, I browse, and no history is ever saved when I restart the browser. No bookmarks get saved either, and if I bookmark a page (sometimes before it hasn't even let me), it won't even show up in the bookmarks menu. And it's also worth noting that the history always never saves either.

What does work: Firefox preferences are saved, add-ons, configurations, downloads, extensions, and anything else that isn't explicitly bookmarks or browsing history. Don't know about form history since I don't use that.

I use Firefox 24 on Ubuntu 13.04.

Please help me, I've run out of options and ideas!

share|improve this question
1  
Disable all your add-ons and extension and try again. –  bodhi.zazen Sep 30 '13 at 16:40
    
Tried it, didn't work. –  Seann Nov 21 '13 at 13:47
    

2 Answers 2

up vote 0 down vote accepted

It's probably not much of a solution, but I installed Google Chrome, imported everything from Firefox, then nuked everything "Mozilla" related. Then I upgraded to 13.10, nuked Unity, switched to Cinnamon, reinstalled Firefox, imported everything back from Chrome, installed LastPass on BOTH, and now it's all good.

share|improve this answer
    
Look at my answer –  AgentCool Nov 21 '13 at 13:52
    
Yes, I read those during my original research on the Mozine/KB, which I stated didn't work. –  Seann Nov 21 '13 at 13:55

Open your Firefox & go to Help > Troubleshooting Information

There you will have a reset button , that will restores the Firefox to its normal behavior. enter image description here

For more information

https://support.mozilla.org/en-US/products/firefox/fix-problems/firefox-wont-save-settings-or-remember-information

share|improve this answer
    
That didn't work either. –  Seann Nov 21 '13 at 13:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.