Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Ubuntu 13.04 PC. Now, using gparted I have partitioned an ntfs file system to install Windows 7. But it seems that Windows 7 did not install any of the partition stating the selected partition is of type gpt. Now moreover trying to format, I have formatted my grub bootloader. So I can't boot to Ubuntu either. Now I have a live Ubuntu usb. But before fixing the grub, I would like to know how can I install Windows without deleting my entire Ubuntu and hard-disk? I can't do that. I have formatted the partition to ntfs using gparted. Why does Windows still give me the gpt error? Is there any way to do it? Or someone please tell me to stop trying.

share|improve this question

1 Answer 1

Windows installs only to Master Boot Record (MBR) disks on BIOS-based computers and only to GUID Partition Table (GPT) disks on EFI-based computers. Linux, OTOH, is more flexible; it can install to GPT on BIOS-based computers, and in some cases it's possible to install to MBR on EFI-based computers. (The Ubuntu installer disallows the latter, IIRC.)

In any event, if your computer has an EFI, you should be able to proceed by forcing the Windows 7 installer to boot in EFI mode. You may be able to do this by selecting a CD/DVD boot device with "EFI" or "UEFI" in the description in the firmware's boot manager; or you may need to play games with the installation medium to get it to boot in EFI mode. I don't happen to have any URLs handy, but Googling on "boot Windows 7 installer in EFI mode" might turn something up.

If your computer has a conventional BIOS with no EFI support, your best option is to convert your disk from GPT to MBR format. You can do this with gdisk; see this section of the gdisk documentation for details on how to do this. Note that you may need to resize partitions, and you'll need to ensure that the NTFS partition you created for Windows must be a primary partition once it's converted to MBR form.

In either case, you'll need to re-install or re-enable a Linux boot loader after you've installed Windows. The Boot Repair utility can usually do this. In the case of an EFI-mode boot, you could also try a number of alternative EFI boot loaders.

share|improve this answer
    
My computer does support UEFI.There is a secure boot option in the bios menu. Still the problem exists –  user196557 Sep 30 '13 at 16:43
    
Everywhere I googled It says that i should delete my entire ubuntu which I can't do. –  user196557 Sep 30 '13 at 16:50
    
My Web page on DUET includes a procedure ("Installing Windows Under DUET") that might work for you (without DUET). It involves copying the Windows files to a USB flash drive and rendering it bootable by setting up the Windows boot loader on that drive. In step #3, though, copy bootmgfw.efi to EFI/BOOT/bootx64.efi on the USB flash drive (you may need to create that directory). Beyond this, I recommend you ask on a Windows forum, since booting Windows in EFI mode is a Windows question. –  Rod Smith Oct 1 '13 at 23:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.