Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently moved from Microsoft WIndows 8 to Ubuntu 12.04. I have Dell Inspiron 3521 but the Wireless or wifi is not working. I tried through additional drivers but a message is alerted that Proprietary drivers are not available or suppoted. check var/log/jockey. Please Help me regarding this problem as I need much to solve this. Thanks.

Output for lspci is:

00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
02:00.0 Network controller: Broadcom Corporation Device 4365 (rev 01)

Output forsudo lshw -c network is:

       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 05
       serial: e0:db:55:da:b4:2c
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8105e-1.fw ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:41 ioport:2000(size=256) memory:c0404000-c0404fff memory:c0400000-c0403fff
  *-network UNCLAIMED
       description: Network controller
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:c0500000-c0507fff

Output for rfkill list all is:

1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
share|improve this question
Please open a terminal, execute following commands. Copy the output and post in your question. You can edit your question. Commands to execute lspci, sudo lshw -c network , rfkill list all – Web-E Sep 30 '13 at 15:52
Do you have your Windows Installation Disc? did <br> you erase windows 8 from your PC while<br> installation? Also which hardware you have(NIC?), Did you<br> click install updates during installation, ? Please check this thread out : <br><br>; Also can you see you Wifi Identification name (or whatever) in your Wifi list? You can access it thorough the top~ right corner of your screen where there is a black bar with a Wifi icon. ~Sid123 – Sids123 Sep 30 '13 at 15:56
I have updated my answer. – Raja Sep 30 '13 at 16:07
I posted the output for 'lspci', 'sudo lshw -c network', 'rfkill list all'. – Jawad Khan Oct 1 '13 at 16:23
See the second answer in this link… – Web-E Oct 9 '13 at 2:19

I have found something interesting for you , Ubuntu have developed their ISO for your Laptop which will consists of all drivers inside. I mean along with your Ubuntu you can have the drivers installed.

The Dell Inspiron 3521 portable has been awarded the status of Certified for Ubuntu. Please note that for pre-installed systems:

The system is available in some regions with a special image of Ubuntu pre-installed by the manufacturer. It takes advantage of the hardware features for this system and may include additional software. You should check when buying the system whether this is an option.

Standard images of Ubuntu may not work at all on the system or may not work well, though Canonical and computer manufacturers will try to certify the system with future standard releases of Ubuntu.

Yes you can check here that

The ISO have drivers too.enter image description here

share|improve this answer
are you sure the iso include the drivers (and there is not certification for wifi device)?because it is pointing to old normal ISO release. Secondly The user clearly tells he is coming from windows 8 so from where he will get system image? and on third, when he tried to install driver via jokey, it exited with error, which probably cased because of missing kernel header. – Web-E Sep 30 '13 at 15:56
@Web-E please look at my updated answer.that will clarifies everything. – Raja Sep 30 '13 at 16:08
Thanks for the clarification.. but at end does this answer resolves the op's problem? Because he is using 12.04, according to this answer it should work out of the box but it is not. :) – Web-E Sep 30 '13 at 18:08
Yes... .the ubuntu ISO in that link have pre loaded drivers of the OP system. So if he download and install that ISO then problem will be solved. – Raja Oct 1 '13 at 0:10
PLease Help me to solve this problem. – Jawad Khan Oct 2 '13 at 1:42

I think will help you. I like to use WICD because it is a simple and easy to use network manager. Its a very good alternative to network manager in Ubuntu and it seems to always work when Network Manager doesn't. To install it just open up the terminal. Now download the latest NetworkManager, in case you need to reinstall it if WICD doesn't work

sudo apt-get install -d --reinstall network-manager network-manager-gnome 

Then to install it

sudo apt-get install wicd-gtk 

And now you need to uninstall NetworkManager:

sudo apt-get remove --purge network-manager-gnome network-manager 

Now you can find WICD in your menu Start WICD, find the network you want to use and enter the information needed, password, encryption, etcetera and choose Automatically Connect to this network. You should be good to go!

WICD may also be available in Ubuntu Update Manager so you can look there first but it is important to uninstall Network Manager completely to prevent conflicts!!

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – fossfreedom Sep 30 '13 at 19:20
Hello FossFreedom, thanks for telling me that. I thought reprinting older threads was not allowed. Good to know! – Ronshere Sep 30 '13 at 23:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.