Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am trying to install redis like here. But when do make, got error unsupported locale setting:

# make
Sorry, command-not-found has crashed! Please file a bug report at:
Please include the following information with the report:

command-not-found version: 0.3
Python version: 3.3.1 final 0
Distributor ID: Ubuntu
Description:    Ubuntu 13.04
Release:    13.04
Codename:   raring
Exception information:

unsupported locale setting
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/CommandNotFound/", line 24, in crash_guard
  File "/usr/lib/command-not-found", line 69, in main
  File "/usr/lib/command-not-found", line 40, in enable_i18n
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python3.3/", line 541, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
share|improve this question
edited my answer. eye it –  Raja Sep 30 '13 at 15:40

1 Answer 1

up vote 2 down vote accepted

Install all the locals

sudo apt-get install language-pack-id

and then configure

sudo dpkg-reconfigure locales

then try again.

Ok configure them manually .

paste these lines one after one

export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
sudo dpkg-reconfigure locales
share|improve this answer
Done. The same error. –  Maxim Yefremov Sep 30 '13 at 15:32
manual configuration was successfull. Thank you –  Maxim Yefremov Sep 30 '13 at 15:44
@efr glad to hear that. –  Raja Sep 30 '13 at 15:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.