Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the following error when trying to install QGIS 2.0.1.2 on Ubuntu 12 or Ubuntu 13

  • I'm using this tutorial: http://www.digital-geography.com/install-qgis-2-0-on-ubuntu/

    - The following packages have unmet dependencies:
    - qgis: Depends: libc6 (>= 2.14) but 2.15-0ubuntu20.1 is to be   
       installed
    - Depends: libgcc1 (>= 1:4.1.1) but 1:4.7.2-2ubuntu1 is to be installed
    - Depends: libgdal1-1.7.0 but it is not going to be installed
    - Depends: libgeos-c1 (>= 3.2.2) but 3.3.8-2~quantal1 is to be installed
    - Depends: libqt4-network (>= 4:4.5.3) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
    - Depends: libqt4-sql (>= 4:4.5.3) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
    - Depends: libqt4-svg (>= 4:4.5.3) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
    - Depends: libqt4-xml (>= 4:4.5.3) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
    - Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
    - Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
    - Depends: libqtwebkit4 (>= 2.2~2011week36) but 2.2.1-4ubuntu1 is to be installed
    - Depends: libspatialite3 (>= 2.4.0~rc2) but 3.1.0~rc2-2~quantal2 is to be installed
    - Depends: libsqlite3-0 (>= 3.5.9) but 3.7.13-1 is to be installed
    - Depends: libstdc++6 (>= 4.4.0) but 4.7.2-2ubuntu1 is to be installed
    - Depends: qgis-providers (= 2.0.1-2+precise1) but 2.0.1-2+precise1 is to be installed
    - Depends: qgis-common (= 2.0.1-2+precise1) but 2.0.1-2+precise1 is to be installed
    
  • After installing Ubuntu 13.04 I have less unmet dependencies:

        Depends: python-qgis-common (= 2.0.1-2 + precise1) but it is not installable
    - Depends on: libqgis2.0.1 but it is not installable
    - Depends on: sip-api-8.1 but it is not installable
    - Qgis:
    - Depends on: libgdal1-1.7.0 but it is not installable
    - Depends on: libqgis2.0.1 but it is not installable
    - Depends: but qgis-providers (= 2.0.1-2 + precise1) should not be installed
    - Recommends: qgis-plugin-globe but it is not installable
    - Qgis-plugin-grass:
    - Depends on: libgdal1-1.7.0 but it is not installable
    - Depends on: libqgis2.0.1 but it is not installable
    - Depends on: grass641 but it is not installable
    - E: Problems can not be corrected, you have held broken packages back.
    
share|improve this question

2 Answers 2

up vote 7 down vote accepted
+100

May be you are doing some mistake.. I recommend you to follow the official website of Qgis to install it in Ubuntu 13.04.

I'm listing the way how to install:

1st way to install QGIS (preferred.)

  1. First remove already added repositories which you tried to install Qgis:

    • Execute this in your terminal: sudo software-properties-gtk and go to Other Software tab.

    • Then remove those repositories that you added using your mentioned tutorial. Find names similar to http://qgis.org/debian and ubuntugis-unstable. Close the window.

    • The execute this command in terminal to update your repository: sudo apt-get update

  2. Now add the QGIS repository once again to your /etc/apt/sources.list file. Do it by following these steps:

    • Open terminal and execute:

      sudo gedit /etc/apt/sources.list
      
    • Add following lines at the last line:

      deb     http://qgis.org/debian raring main
      deb-src http://qgis.org/debian raring main
      
    • Save the file and close the window.

    • Execute following two commands to add public key of QGIS

      gpg --keyserver keyserver.ubuntu.com --recv 47765B75
      gpg --export --armor 47765B75 | sudo apt-key add -
      
    • Update repository by executing following command:

      sudo apt-get update
      
  3. Now install QGIS by following these steps:

    • First remove already installed QGIS or any residual( and broken) packages if any:

      sudo apt-get autoremove
      sudo apt-get autoclean
      sudo apt-get -f install
      sudo apt-get autoremove qgis
      sudo apt-get --purge remove qgis
      
    • Install grass plugin:

      sudo apt-get install grass
      sudo apt-get install qgis-plugin-grass
      
    • Finally install QGIS:

      sudo apt-get install qgis python-qgis
      

2nd way to install *QGIS via Ubuntugis repository:*

You can also install QGIS by adding Ubuntugis repository. (The ubuntugis project provides newer versions of various FOSSGIS packages, QGIS being one of them.)

  • First remove http://qgis.org/debian lines from your /etc/apt/sources.list. 2nd step in my first method can help you how to remove.

  • Then executes these commands:

    sudo apt-get install python-software-properties
    sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
    sudo apt-get update
    sudo apt-get install qgis python-qgis qgis-plugin-grass
    

It should install without any problem. Reply if something goes wrong..

Source: www.qgis.org

share|improve this answer

The error message you get simply tells you that some dependencies cannot be installed from the "standard" Ubuntu repository (for your version of Ubuntu).

For exemple python-qgis-common (from the package you are trying to install) depends on libqgis2.0.1

However if you look at the version of this package installed by Ubuntu in the official standard repository:

http://packages.ubuntu.com/search?suite=default&section=all&arch=any&keywords=libqgis&searchon=names

You can see the the version supported by Ubuntu (from their official repo) is 1.7.5 for Raring and up. Nothing for Precise ...

Well Ubuntu is always late to support the latest version of any non core software.

However I did manage to install the latest version QGIS on my Ubuntu 12.04 Precise simply by visiting the QGIS.org website:

http://hub.qgis.org/projects/quantum-gis/wiki/Download

When in trouble it is always better to refer to the website of the organization.

Then look at Chapter 2.6 Ubuntu

The repositories are to be added to the file /etc/apt/sources.list by issuing:

sudo gksu gedit /etc/apt/sources.list

Then run the usual

sudo apt-get update
sudo apt-get install qgis

The response in the command line will recommend you to install the following packages:

qgis-plugin-grass pyhton-qgis qgis-plugin-globe

Get some information on whether you need to install them.

That's it. No more bla-bla. I usually prefer to understand the commands & actions I take to correct a problem. There is no better source than the original developper.

share|improve this answer
    
Thank you for your answer! Haven't tried it out because QGIS works now (Also I'm afraid to break it again because I'm very new to Ubuntu). All the best! –  Spießbürger Oct 9 '13 at 10:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.