Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have my machine connected to our office LAN which has many other machines that use win XP, win 7 etc. Until a month or so ago, I was able to share files and folders with them, but now I can't even see what machines are there on my LAN, let alone access their files. I tried accessing a machine by its name, by opening smb://machinename, but that says

Error: Failed to retrieve share list from server
Please select another viewer and try again.

I tried restarting samba with sudo service samba restart, but that says samba: unrecognized service, but then samba is shown as installed in synaptic.

I am pretty much stuck on this. Any ideas on how to fix this?

share|improve this question

3 Answers 3

Basically you can try viewing network in nautilus with network:/// in nautilus location bar. As for restarting samba server I think try replacing samba in your service command with smb or smbd. Or try using machine ip rather than machine name.

share|improve this answer
1  
The network:/// shows me one entry, "Windows Network" and opening it fails with the error "Unable to mount location". Getting the IP address is not always practical, as the machine is in the other corner of this huge office :) –  Shrikant Sharat Apr 15 '11 at 5:53
    
ubuntuforums.org/showthread.php?t=1082148 May be you could try instructions from this forum –  sagarchalise Apr 15 '11 at 6:13
    
Oh yeah, on post on that thread mentions the firewall, which turned out to be my problem. damn! Thanks a lot, problem solved :). –  Shrikant Sharat Apr 15 '11 at 6:21
up vote 0 down vote accepted

The problem turned out to be the firewall. Disable it with

sudo ufw disable

did the trick.

share|improve this answer

A bit too late answer but seems some people are still experiencing same problem. It is often happen that the problem lays not on client side (Ubuntu) but on server-side.

First of all I would suggest to check the firewall settings on Windows side. For example on Windows 7 I had to open TCP port 445 for SMB and UDP 137, 138 / TCP 137, 139 for NetBios API.

In order to do this go to Windows box and open:

Control Panel > Firewall > Advanced Settings > Inbound Rules > Add Rule... 

Add rules for each port mentioned above. Then you may try to connect from Ubuntu. In case you are still not able to connect - open the terminal and run commands to see shares

$ findsmb
$ smbtree

(hit enter when prompted for a password)

From the output of smbtree find the Windows station name and run

$ smbclient -L [NAME]

Since this moment you will be either connected to Share or will get an error code which will give you a hint about the origin of problem. For example, my error message was NT_STATUS_BAD_NETWORK_NAME (Windows computer name contained not allowed character) and the problem was fixed in 2 minutes.

Hope this information will be helpful.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.