Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The lid switch of the notebook Lenovo Thinkpad X230i had worked just fine: closing the lid lead to a suspend as expected. After an update of the system on the 18th of September1 the lid switch seems to be not recognized anymore.

If I manually click on "Suspend", it works fine, so suspending is not the core of the problem.

I tried to read the "Lid" state, by entering while [ 1 ]; do cat /proc/acpi/button/lid/LID/state; sleep 1; done in the terminal and also by trying watch -n 4 'upower -d | grep lid-', but the reported lid state is always "OPEN". My strong assumption is that the lid switch did not physically break at the same time when I did the update. Also, the notebook is just three weeks old.

Is there a way that I can fix the correct reading of the lid state in Ubuntu? Thanks a lot for your help!

The log of the update 18th Sept is here.

share|improve this question

2 Answers 2

It seems that the problem comes from the lack of systemd according to http://www.infty.nl/wordpress/2012/12/gnome-3-on-ubuntu-raring-and-suspend/.

From the same webpage, there is a workaround: put the following into /etc/acpi/local/lid.sh.post, and make it executable.

#!/bin/bash

grep -q closed /proc/acpi/button/lid/*/state
if [ $? = 0 ]; then
   pm-suspend
fi
share|improve this answer
    
Thanks Sachin for your quick answer. Unfortunately, the workaround does not work for me. I assume that I have a somewhat lower level problem, because the state in /proc/acpi/button/lid/*/state never changes anymore to "closed". –  Gerry T. Sep 30 '13 at 9:31
    
Since Sachin hinted to systemd in his previous comment, I had a look again at the update log (see link above). Is it possible that an update of these packages here "destroyed" Ubuntu's ability to read the lid switch state? –  Gerry T. Sep 30 '13 at 9:58
    
These here: *** 2013-09-18 21:03:35 upgrade libudev-dev:amd64 198-0ubuntu11.1 198-0ubuntu11.2 *** 2013-09-18 21:03:36 upgrade libudev1:i386 198-0ubuntu11.1 198-0ubuntu11.2 *** 2013-09-18 21:03:38 upgrade libudev1:amd64 198-0ubuntu11.1 198-0ubuntu11.2 *** 2013-09-18 21:04:04 upgrade libsystemd-daemon0:amd64 198-0ubuntu11.1 198-0ubuntu11.2 *** 2013-09-18 21:04:05 upgrade libsystemd-login0:amd64 198-0ubuntu11.1 198-0ubuntu11.2 *** 2013-09-18 21:04:06 upgrade systemd-services:amd64 198-0ubuntu11.1 198-0ubuntu11.2 *** 2013-09-18 21:04:33 upgrade ubuntu-system-service:all 0.2.4 0.2.4.1 –  Gerry T. Sep 30 '13 at 9:59
    
Assuming this might be a systemd/libudev problem I added a question here: bugs.launchpad.net/ubuntu/+source/systemd/+bug/1233091 Do you think the problem could be related to the update of that package? –  Gerry T. Sep 30 '13 at 10:45
up vote 0 down vote accepted

Thanks for the help. I figured out that it actually is a hardware problem with the lid switch. Just closing the lid does not lead to recognition of the closure by the switch. I need to press with a finger at a particular point on the lid. This is a hardware and not software problem. Thanks!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.