Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just bought a Toshiba Satellite L75D-A7280. Immediately dropped Windows 8 for ArtistX. Apparently corrupted .iso, so I reinstalled with a new .iso (after they upgraded their build to 13.04, apparently) then just decided the whole thing was just too bloated so decided the smartest thing for someone that hasn't ever touched a terminal to do is go to the last LTS, 12.04. Throughout all of my ridiculous floundering there has been one constant since dropping Windows; no wireless support.

I am currently on the machine in question hooked directly to my router. No problems there. I've tried going on the Toshiba support website and downloading the drivers but there's no indication I'm not doing it wrong.

I've done some looking around online and learned to type lshw and, concerning the network, I get this:

*-network UNCLAIMED
              description: Network controller
               product: RTL8188EE Wireless Network Adapter
               vendor: Realtek Semiconductor Co., Ltd.
               physical id: 0
               bus info: pci@0000:05:00.0
               version: 01
               width: 64 bits
               clock: 33MHz
               capabilities: bus_master cap_list
               configuration: latency=0
               resources: ioport:2000(size=256) memory:f0100000-f0103fff

and also, and it may be an unrelated issue, I have a serial saying it's unclaimed as well. It's a Hynex Semi-Conductor, apparently. I don't know what that is.

I'm seeing a lot of posts about the RTL8188 but they seem to be in Greek (or Unix, very little difference to me) so if someone could ELI5 (or like I'm a 30 year old man that has only just now walked away from Windows, anyway) I would appreciate it greatly. Kinda dove in head first and landed immediately over my head I guess.

share|improve this question
    
Here is the process to install the driver for your device. It was tested and written for 13.04 but will probably but not necessarily work for 12.04 LTS. I suggest you try it: askubuntu.com/questions/337785/… –  chili555 Sep 29 '13 at 22:59
    
OK. Just tried it. After 'sudo make install' every other line is 'cannot read private key'. And after reboot it still doesn't work. What does that mean? –  EvolArtMachine Sep 29 '13 at 23:31
    
If you can spare $15, this is a good, Linux-compatible wifi card that you can plug into your USB port. I use it myself, and it works great. –  Dillmo Sep 29 '13 at 23:45
    
thanks. if i can't get this thing beat with good old fashioned american bullheadedness, at least i know i have an out. –  EvolArtMachine Sep 29 '13 at 23:48
    
So, you've found the product code for your wireless card. Now, for starters, check to see if the firmware is there for your card. To do this launch the terminal and type: cd /lib/firmware ls -l –  Brian Sep 29 '13 at 23:48
show 6 more comments

2 Answers 2

Here is the link or follow the link above (Chili555) Followed the directions it works good it says for a Toshiba C55 A5281 and Ubuntu 13.04, I have a Toshiba Satellite L75D-A7280, Ubuntu 12.04LTS all updates and 3.11.4 kernel, Wireless not working on Toshiba Satellite C55-A5281

share|improve this answer
add comment

You should give this driver a try: https://github.com/FreedomBen/rtl8188ce-linux-driver

After having many issues with my RTL8188CE I finally downloaded the driver source code and fixed it myself. It has been working beautifully for me ever since. Make sure you download the one for your OS version. For example, if you're on 12.04 then switch to the ubuntu-12.04 branch. The latest version on master is for 13.10 and the kernel headers have changed so the are NOT compatible.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.