Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I go to my Xampp control panel and press "EXECUTE" for MySQL it refuses to run. It is a completely accurate and clean/fresh install. I'm running 10.10. Here is the error log:

110414 18:43:52 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The first specified data file ./ibdata1 did not exist:
InnoDB: a new database to be created!
110414 18:43:52  InnoDB: Setting file ./ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
110414 18:43:52  InnoDB: Log file ./ib_logfile0 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
110414 18:43:52  InnoDB: Log file ./ib_logfile1 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
110414 18:43:53  InnoDB: Started; log sequence number 0 0
110414 18:43:53  InnoDB: Starting shutdown...
110414 18:43:58  InnoDB: Shutdown completed; log sequence number 0 44233
110414 18:43:58 [Note] Plugin 'FEDERATED' is disabled.
110414 18:43:58  InnoDB: Started; log sequence number 0 44233
110414 18:43:58  InnoDB: Starting shutdown...
110414 18:44:03  InnoDB: Shutdown completed; log sequence number 0 44233
110414 18:44:03 [Note] Plugin 'FEDERATED' is disabled.
110414 18:44:04  InnoDB: Started; log sequence number 0 44233
 ERROR: 1064  You have an error in your SQL syntax; check the manual that corresponds 
to  
your MySQL server version for the right syntax to use near 'ALTER TABLE user ADD  
column    
Show_view_priv enum('N','Y') CHARACTER SET utf8 NOT ' at line 1
110414 18:44:04 [ERROR] Aborting

110414 18:44:04  InnoDB: Starting shutdown...
110414 18:44:09  InnoDB: Shutdown completed; log sequence number 0 44233
110414 18:44:09 [Note] /usr/sbin/mysqld: Shutdown complete

110414 18:44:09 [Note] Plugin 'FEDERATED' is disabled.
110414 18:44:09  InnoDB: Started; log sequence number 0 44233
110414 18:44:09  InnoDB: Starting shutdown...
110414 18:44:14  InnoDB: Shutdown completed; log sequence number 0 44233
110414 18:44:14 [Note] Plugin 'FEDERATED' is disabled.
110414 18:44:15  InnoDB: Started; log sequence number 0 44233
ERROR: 1050  Table 'plugin' already exists
110414 18:44:15 [ERROR] Aborting

110414 18:44:15  InnoDB: Starting shutdown...
110414 18:44:20  InnoDB: Shutdown completed; log sequence number 0 44233
110414 18:44:20 [Note] /usr/sbin/mysqld: Shutdown complete

110414 18:44:21 [Note] Plugin 'FEDERATED' is disabled.
110414 18:44:21  InnoDB: Started; log sequence number 0 44233
110414 18:44:21 [Note] Event Scheduler: Loaded 0 events
110414 18:44:21 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.49-1ubuntu8.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  
(Ubuntu)
110414 18:56:29 [Note] /usr/sbin/mysqld: Normal shutdown

110414 18:56:29 [Note] Event Scheduler: Purging the queue. 0 events
110414 18:56:32  InnoDB: Starting shutdown...
110414 18:56:47  InnoDB: Shutdown completed; log sequence number 0 44233
110414 18:56:47 [Note] /usr/sbin/mysqld: Shutdown complete

110414 18:57:39 [Note] Plugin 'FEDERATED' is disabled.
110414 18:57:42  InnoDB: Started; log sequence number 0 44233
110414 18:57:42 [Note] Event Scheduler: Loaded 0 events
110414 18:57:42 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.49-1ubuntu8.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306   
(Ubuntu)
110414 19:21:14 [Note] /usr/sbin/mysqld: Normal shutdown

110414 19:21:15 [Note] Event Scheduler: Purging the queue. 0 events
110414 19:21:17  InnoDB: Starting shutdown...
110414 19:21:18  InnoDB: Shutdown completed; log sequence number 0 44233
110414 19:21:18 [Note] /usr/sbin/mysqld: Shutdown complete

110414 19:23:40 [Note] Plugin 'FEDERATED' is disabled.
110414 19:23:40  InnoDB: Started; log sequence number 0 44233
110414 19:23:41 [Note] Event Scheduler: Loaded 0 events
110414 19:23:41 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.49-1ubuntu8.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306    
(Ubuntu)
110414 19:25:40 [Note] /usr/sbin/mysqld: Normal shutdown

110414 19:25:40 [Note] Event Scheduler: Purging the queue. 0 events
110414 19:25:40  InnoDB: Starting shutdown...
110414 19:25:41  InnoDB: Shutdown completed; log sequence number 0 44233
110414 19:25:41 [Note] /usr/sbin/mysqld: Shutdown complete

110414 19:26:26 [Note] Plugin 'FEDERATED' is disabled.
110414 19:26:27  InnoDB: Started; log sequence number 0 44233
110414 19:26:27 [Note] Event Scheduler: Loaded 0 events
110414 19:26:27 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.49-1ubuntu8.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)
share|improve this question
    
Try removing the CHARACTER SET utf8 reference . Here's some more info : Xammp/MySQL issue –  belacqua Apr 15 '11 at 4:35
add comment

2 Answers 2

Try running the regular MySQL (that you get via Synaptic). Really, there's not much of a benefit to running XAMPP in Ubuntu, when you can easily install the components on your machine and easily get the same or enhanced functionality.

@jgbelacqua gives a link to an issue with UTF-8 and suggests removing the UTF-8 reference. I didn't read his link carefully enough to know if it was suggesting using some other character set, but if so, it's bad advice. MySQL certainly supports UTF-8 and there are very many good reasons why you should be using it, too. If the version of MySQL supplied with XAMPP can't handle that, then XAMPP is buggy and should be abandoned.

share|improve this answer
add comment

Why not install LAMP server? xampp is very buggy and i got problems with it on every platform. Last releases have very serious problems with MySql, it's just not working!

just do

sudo apt-get install php5 php5-mysql phpmyadmin mysql-server-5.1 apache2

and ur done.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.