Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sony VAIO S series with Windows 8 preinstalled and then I installed Ubuntu 12.10 partition.

The first time I was booting the Grub appeared, and I was able to choose between Windows 8 and Ubuntu 12.10. The problem is that when I select Windows 8 the Grub doesn't appear anymore and it boots always on Windows.

I read a bout this command in a Windows command prompt:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Seems like the command worked in the sense that you can see again the purple Grub menu at boot, and it also works when you select Ubuntu however, if you select to boot Windows 8 from Grub, you get the following two errors:

error: can't find command 'drivemap'
error: invalid EFI file path.
share|improve this question
    
Have a look at this question (possible duplicate - please check) –  the_Seppi Sep 29 '13 at 17:32
    
See this - Installing Ubuntu on a Pre-Installed Windows 8 (64-bit) System (UEFI Supported), and make sure you followed it correctly.Most probably secure boot is causing the problem. –  Web-E Sep 29 '13 at 17:48
    
I already try with both solutions when I repair the boot from ubuntu im able to select again between ubuntu and windows but then after selecting windows it overwrites the boot and I cant select Ubuntu...any ideas? –  kobayashi Sep 30 '13 at 0:28
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.