Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new in Linux. Just installed Ubuntu 12.04 and I installed some updates so I can use aircrack-ng. When I write mixa@mixa-Lenovo-G780:~$ sudo airmon-ng start eth1, I get:

Found 4 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
890 avahi-daemon
891 avahi-daemon
897 NetworkManager
911 dhclient


Interface   Chipset     Driver


mixa@mixa-Lenovo-G780:~$

And on other Linux (Kali Linux), I had same problem. I had nothing under interface, chipset, and driver.

How to fix it?

share|improve this question

2 Answers 2

First of all, you need to have an wireless interface like wlan0 to use airmon-ng and as I can see from your output, you don't have it. I deduced this because the output for these fields Interface Chipset Driver is empty.

share|improve this answer

airmon-ng is used to put wireless interfaces into monitor mode, so that you can capture packets (the equivalent of "promiscuous mode" on Ethernet cards).

The command that you are trying airmon-ng start eth1 is trying to turn on monitor mode for eth1, which is an Ethernet interface, not your wireless interface, so it will not work. You need to use airmon-ng for your wireless interface. Your wireless interface is usually wlan0.

To find out the exact name of your wireless interface, you can execute the command iwconfig, which should show you something like this:

alaa@aa-lu:~$ iwconfig

wlan0     IEEE 802.11bgn  ESSID:"Alaa"  
          Mode:Managed  Frequency:2.472 GHz  Access Point: xx:xx:xx:xx:xx:xx   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=58/70  Signal level=-52 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:514   Missed beacon:0

vmnet8    no wireless extensions.

lo        no wireless extensions.

eth0      no wireless extensions.

vmnet1    no wireless extensions.

From the output, you can see that wlan0 is a wireless interface.

So, the command to turn on monitor mode for wlan0 is sudo airmon-ng start wlan0.

If however, you don't have a wireless interface (which is probably the case, looking at your output), then I need to ask the question of why do you want to run airmon-ng when you don't have a wireless card?

If you're installing this Ubuntu (or Kali) as a virtual machine, then aircrack-ng will never work, because a virtual machine will always see an Ethernet card, not the wireless card. The only way you can make a virtual machine see a wireless card is by using a wireless USB adapter, such as this one:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.