Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Radio Tray icon will not show in Ubuntu 11.04 (Natty Narwhal) Beta 2 under Unity, but it works in classic mode.

I have it set as a startup application using the command /usr/bin/radiotray. It loads perfectly in classic mode, but not at all in Unity.

How can I get Radio Tray to work when I use Unity?

share|improve this question

closed as too localized by Tom Brossman, Mik, Eliah Kagan, LnxSlck, hexafraction Oct 28 '12 at 21:34

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
This is bug 717777. –  poolie Apr 19 '11 at 1:36
add comment

6 Answers 6

The latest version from sourceforge (at the time of writing this, it is version 0.6.4) now has both app-indicator support (for Natty) and notification area support (for other ubuntu variants and versions before 11.04).

Install the application via

cd Downloads 
sudo dpkg -i radiotray_0.6.4_all.deb

then start the application:

nohup radiotray &

this will display the choice screen:

enter image description here

Click OK for Natty (or change the option).

Radiotray should appear in the app-indicators area of Natty.

To get Radiotray starting automatically - open Natty dash and search for startup application. You can then add a new entry with the command line radiotray

share|improve this answer
add comment

Well I donot know if this will work for radio tray but it is working for covergloobus and gnote in my case. To add custom notification tray in unity

First do :

gsettings get com.canonical.Unity.Panel systray-whitelist

to see the systray whitelist.

then append

gsettings set com.canonical.Unity.Panel systray-whitelist "['your settings here', 'radiotray']"

EDIT: Webupd8 explains your need

share|improve this answer
    
I don't think radiotray is the right id for this applet, or at least it doesn't work for me. –  poolie Apr 19 '11 at 1:31
    
May be you try RadioTray. Or I have edited to add a link for webupd8 where I think it's the same thing that fossfreedom explains –  sagarchalise Apr 19 '11 at 3:47
    
This does work for me in Ubuntu 12.04 with radiotray 0.7.2. radiotray was missing in this whitelist. –  king_julien Dec 25 '13 at 20:02
add comment

I just installed this program in Ubuntu 12.04. Ran it first time OK then it refused to open again. The initial startup script gives the option to enable the "Gnome Media Keys" plugin. I had enabled this option and it seems that this is what prevented the application from starting again.

The solution was to remove the Gnome Media Keys section from the active plugins line in the config.xml file. Works fine after that.

share|improve this answer
add comment

Unity does not support gnome-applets, and most applications will not work in the system tray (notification area) unless they are ported to indicator applets, so it is unlikely that radiotray will work in this situation.

share|improve this answer
    
Tray icons still work in a transition period, they just need to be whitelisted. –  Egil Apr 15 '11 at 6:12
    
@Egil: I know but not all icons are working if you whitelist them (in my experience). –  RolandiXor Apr 15 '11 at 15:15
add comment

This website shows you how.
http://www.webupd8.org/2011/04/how-to-enable-ubuntu-appindicator-for.html

share|improve this answer
    
-1 for only providing a link. The best practice to write instructions in your own words and attribute the source, including a link. –  Firefeather May 13 '11 at 17:02
add comment

Although radiotray now has application indicator support the default setting is set to "false" when it should be set to "true". You will find the configuration file in the home folder at /.local/share/radiotray/config.xml. You will need to set file manager to show hidden files in order to see the .local folder. The dot ( . ) makes the file hidden from normal file manager use.

These are the lines to change:

Change false to true. While you are there change the default sleep_timer value from 15 to 60 or 120 otherwise radiotray will stop working after 15 minutes. And you will find that you cannot reset it unless you reboot.

This is the command to put in a terminal to both load gedit and the document config.xml. You need to use sudo to let you save the changes.

gksudo gedit ~/.local/share/radiotray/config.xml

Did is what I had to do to get radiotray working under Unity just a few days ago.

Regards.

share|improve this answer
add comment