Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried alot of different ways to get my pc working with graphics card but hasnt got me anywhere. I started off with installing ubuntu 12.04 for the first time which left me stuck at black login screen. (solved now).

I have tried bubmlebee method and installing driver from Nvidia directly but both didnt work. (I’ve got removed Nvidia* now since it didnt work) with bumblebee I could not run optirun or prium

lspci -nn | grep -i vga

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)

sudo lshw -C display

*-display UNCLAIMED     
       description: 3D controller
       product: GK106M [GeForce GTX 765M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:45 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

lspci | grep NVIDIA

01:00.0 3D controller: NVIDIA Corporation GK106M [GeForce GTX 765M] (rev a1)

PS: I used http://followthegeeks.com/a-noobs-guide-to-installing-nvidia-optimus-driver-in-ubuntu/ to solve black screen problem.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

You can try downloading driver from xorg edgers ppa(https://launchpad.net/~xorg-edgers/+archive/ppa).

Add the ppa

sudo add-apt-repository ppa:xorg-edgers/ppa

upgrade your system

sudo apt-get update && sudo apt-get upgrade

Reinstall bumblebee.

If that doesn't solve your problem,

what is the error when you run optirun? include in your question.

A note : did you created this question yesterday? Nvidia GTX 765m Optimus tech on ubuntu 12.04 Don't create duplicate each day with different id that doesn't help here to get good answers.

share|improve this answer
    
optirun firefox : [ 745.002097] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected. [ 745.002131] [ERROR]Aborting because fallback start is disabled. I tried to delete the question because server didnt let me log in for some reason...so I had to create duplicate question sorry. –  Rui Sep 29 '13 at 9:57
    
I"ve just checked and it is no longer unclaimed. However bumblebee stays off and overview doesnt show graphics at all... –  Rui Sep 29 '13 at 10:14

After many trials I finally found the problem related with the Kernel. For me this makes the VGA work, you can give it a try. Jump over to a terminal with Ctrl-Alt-F1 :

sudo apt-get install linux-source

sudo apt-get install linux-headers-3.5.0-18-generic

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update

sudo apt-get install bumblebee bumblebee-nvidia

sudo reboot

good luck.

share|improve this answer

Following Web-E answer, after a reboot

   sudo apt-get update 

stopped working. I managed to get it going by following the solution here, in other words by using

   cd /etc/apt/sources.list.d/
   sudo rm xorg-edgers-ppa-trusty.list
   sudo reboot
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.