Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I boot Ubuntu I can see the mouse cursor at the login screen but once I put my password is see this error could not acquire name on session bus I tried to Google the error but all I find is stuff on VNC and I don't use VNC. I do have Teamviewer if that matters.

After the error message I get the desktop but the mouse cursor is invisible.

I'll explain how I got here. I wanted to upgrade to 13.10 to see if my recon3d sound card would work. But when I tried to upgrade I got could not calculate the upgrade and then the update software would close. I read an article saying I needed to run the following command before so I did.

sudo apt-get update && sudo apt-get dist-upgrade

While it was running the PC froze and had to do a hard reset. After that I couldn't boot I was getting an error saying something about filesystem and failed to mount. I fixed that by googling the error. But then I got news problems. First I was getting unable to load session Ubuntu. I got around that somehow by reinstalling some things like desktop-ubunut, xorg, etc but now I'm at this point where in lightdm it boots and I get low graphics mode then the error message could not acquire name on session bus and the invisible mouse cursor. My googling my issue I found stuff about the greeter and something about renaming Xauthority to .old which I did but not sure what to do now or what to try.

I don't know how to rollback to 13.04 or if it would help. I would like to reinstall everything but can't without losing my 2TB of movies. I use 4 500GB HDDs in Raid 0 for a total of 2TB. I read you could reinstall Ubuntu over itself but that tells me it will delete everything even if I didn't check format. I heard you could reinstall Ubuntu package by package but dunno how to do that. Please help me!

share|improve this question
Oh and even tho I never got to do the 13.10 update my os says it's 13.10 now after I fixed the boot problem. – Adrian Sultu Sep 29 '13 at 4:51
After trying sudo apt-get remove --purge gnome-shell I don't even get the desktop anymore. After the low graphics message I get a black screen. But I'm using lightdm not gdm. – Adrian Sultu Sep 29 '13 at 4:53
I also installed the nvidia drivers 325 but nothing is working still. – Adrian Sultu Sep 29 '13 at 4:54
I think my unity-greeter.confg file is missing. Also my lightdm.confg file seems to be blank. – Adrian Sultu Sep 29 '13 at 5:06
After installing gnome-shell and gdm and switching to gdm I no longer get low graphics mode and can login to the desktop but the mouse is invisible and I still get the error message could not acquire name on session bus. – Adrian Sultu Sep 29 '13 at 5:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.